summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Moch2018-10-30 06:21:56 -0400
committerDaniel Moch2018-10-30 06:21:56 -0400
commite1469a8890435d25b2bc91895e075b449f51457e (patch)
tree5551ee086107e37cd3b78fe7fe131205824070f6
parentf24e52eb0c63f6ca3c5a887aa4e649f9c799b7e9 (diff)
downloadaur-e1469a8890435d25b2bc91895e075b449f51457e.tar.gz
upgpkg: python-django-otp 0.5.1-1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
2 files changed, 9 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3e14fa721379..4b2218c7a149 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-django-otp
pkgdesc = A framework for adding two-factor authentication to Django using one-time passwords
- pkgver = 0.5.0
+ pkgver = 0.5.1
pkgrel = 1
url = https://bitbucket.org/psagers/django-otp
arch = any
@@ -10,7 +10,7 @@ pkgbase = python-django-otp
depends = python
depends = python-django
optdepends = python-qrcode: For OTP setup with QR code
- source = django-otp-0.5.0.tar.gz::https://files.pythonhosted.org/packages/6b/05/ecf200287a642703d7d2b1c5776a8de8b2e2cfe7aeefaa242bce859db08e/django-otp-0.5.0.tar.gz
- sha512sums = 4e84674004dbf610cbdf7fa7e8e3ce968860b94f6828441773ad46c98c8742ef762de041870982254e62116d7900b287bb3a2ca79ec70141d2853ed9c2e1ecfb
+ source = django-otp-0.5.1.tar.gz::https://files.pythonhosted.org/packages/source/d/django-otp/django-otp-0.5.1.tar.gz
+ sha512sums = bdce0ef01013bed059ac4cb2c3d4ccb9ce8c6da94451f4b1a8ff8b7ea03e6206d6b357550af6b423aabf17a4bca8065eec171e6b8b16b2a4c05bbb3234d0db20
pkgname = python-django-otp
diff --git a/PKGBUILD b/PKGBUILD
index d2f8be9415b9..005e2446b871 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Daniel Moch <daniel AT danielmoch DOT com>
-
+_pkgname=django-otp
pkgname=python-django-otp
-pkgver=0.5.0
+pkgver=0.5.1
pkgrel=1
pkgdesc="A framework for adding two-factor authentication to Django using one-time passwords"
url="https://bitbucket.org/psagers/django-otp"
@@ -10,16 +10,16 @@ arch=('any')
depends=('python' 'python-django' )
optdepends=('python-qrcode: For OTP setup with QR code')
makedepends=('python' 'python-setuptools')
-source=(django-otp-$pkgver.tar.gz::https://files.pythonhosted.org/packages/6b/05/ecf200287a642703d7d2b1c5776a8de8b2e2cfe7aeefaa242bce859db08e/django-otp-$pkgver.tar.gz)
-sha512sums=('4e84674004dbf610cbdf7fa7e8e3ce968860b94f6828441773ad46c98c8742ef762de041870982254e62116d7900b287bb3a2ca79ec70141d2853ed9c2e1ecfb')
+source=("${_pkgname}-${pkgver}.tar.gz::https://files.pythonhosted.org/packages/source/${_pkgname::1}/${_pkgname}/${_pkgname}-$pkgver.tar.gz")
+sha512sums=('bdce0ef01013bed059ac4cb2c3d4ccb9ce8c6da94451f4b1a8ff8b7ea03e6206d6b357550af6b423aabf17a4bca8065eec171e6b8b16b2a4c05bbb3234d0db20')
build() {
- cd "$srcdir/django-otp-${pkgver}"
+ cd "$srcdir/${_pkgname}-${pkgver}"
python setup.py build
}
package() {
- cd "$srcdir/django-otp-${pkgver}/"
+ cd "$srcdir/${_pkgname}-${pkgver}/"
python setup.py install --root="$pkgdir/" --optimize=1
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}