summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid McInnis2016-02-03 23:05:11 -0800
committerDavid McInnis2016-02-03 23:05:11 -0800
commitccc5288866edc3b28ee3e5b9a5b081edf63a8ae9 (patch)
tree280c443a35b18fe861105d0fdf4ac85e2e4a2eb2
downloadaur-ccc5288866edc3b28ee3e5b9a5b081edf63a8ae9.tar.gz
first commit
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD22
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b7eade6655e8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+# Generated by mksrcinfo v8
+# Thu Feb 4 07:04:58 UTC 2016
+pkgbase = python-django-pgallery
+ pkgdesc = Photo gallery app for PostgreSQL and Django.
+ pkgver = 0.6.1.dev0
+ pkgrel = 1
+ url = https://github.com/zsiciarz/django-pgallery
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python-django
+ depends = python-pillow
+ depends = python-psycopg2
+ depends = python-django-markitup
+ depends = python-django-model-utils
+ source = https://pypi.python.org/packages/source/d/django-pgallery/django-pgallery-0.6.1.dev0.tar.gz
+ sha256sums = 6ec8c7f640151844b4903cfc2bf6ca7104ec095451a392248b4a02869044585a
+
+pkgname = python-django-pgallery
+ depends = python-django
+ depends = python-pillow
+ depends = python-psycopg2
+ depends = python-django-markitup
+ depends = python-django-model-utils
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..126127aa6f76
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+#Maintainer: David McInnis<davidm@eagles.ewu.edu>
+
+pkgbase=('python-django-pgallery')
+pkgname=('python-django-pgallery')
+_module='django-pgallery'
+pkgver='0.6.1.dev0'
+pkgrel=1
+pkgdesc="Photo gallery app for PostgreSQL and Django."
+url="https://github.com/zsiciarz/django-pgallery"
+depends=('python-django' 'python-pillow' 'python-psycopg2' 'python-django-markitup' 'python-django-model-utils')
+makedepends=('python-setuptools')
+license=('MIT')
+arch=('any')
+source=("https://pypi.python.org/packages/source/d/django-pgallery/django-pgallery-${pkgver}.tar.gz")
+sha256sums=('6ec8c7f640151844b4903cfc2bf6ca7104ec095451a392248b4a02869044585a')
+
+package() {
+ depends+=()
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.txt"
+}