summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAmaury Bodet2020-12-02 21:56:03 +0100
committerAmaury Bodet2020-12-02 21:56:03 +0100
commit4b1ba2e505243d65b3685ac3de2ebc2c45c38873 (patch)
treefb7edbfa3af67deb925426a6753a67bbbbbfefbf
downloadaur-4b1ba2e505243d65b3685ac3de2ebc2c45c38873.tar.gz
Initial submission
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD37
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3057df4c927f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-django-rest-knox
+ pkgdesc = Authentication Module for django rest auth
+ pkgver = 4.1.0
+ pkgrel = 1
+ url = https://github.com/James1345/django-rest-knox
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python-cryptography
+ depends = python-django
+ depends = python-django-rest-framework
+ source = python-django-rest-knox-4.1.0.src.tar.gz::https://github.com/James1345/django-rest-knox/archive/4.1.0.tar.gz
+ sha512sums = ff7252e35ed3998d882ba5f857ba7278340065ab849475b0b3d46a04842eac43f38f089fc138ebbe1495a06c4fd4ddb7bd1025a816ae4ad2c646752e74f85336
+
+pkgname = python-django-rest-knox
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a531e990b350
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Contributor: Lucki <https://aur.archlinux.org/account/Lucki>
+# Maintainer: amo <https://aur.archlinux.org/account/amo>
+
+_pkgname=django-rest-knox
+pkgname=python-django-rest-knox
+pkgver=4.1.0
+pkgrel=1
+pkgdesc="Authentication Module for django rest auth"
+arch=('any')
+url="https://github.com/James1345/django-rest-knox"
+license=('MIT')
+depends=('python-cryptography' 'python-django' 'python-django-rest-framework')
+makedepends=('python-setuptools')
+source=("$pkgname-$pkgver.src.tar.gz::https://github.com/James1345/django-rest-knox/archive/$pkgver.tar.gz")
+sha512sums=('ff7252e35ed3998d882ba5f857ba7278340065ab849475b0b3d46a04842eac43f38f089fc138ebbe1495a06c4fd4ddb7bd1025a816ae4ad2c646752e74f85336')
+
+build() {
+ cd "$_pkgname-$pkgver" || exit
+ python setup.py build
+}
+
+# check() {
+# https://wiki.archlinux.org/index.php/Python_package_guidelines#Check
+# > Avoid using tox to run testsuites
+# }
+
+package() {
+ cd "$_pkgname-$pkgver" || exit
+
+ export PYTHONHASHSEED=0
+ python setup.py install --skip-build \
+ --optimize=1 \
+ --prefix=/usr \
+ --root="$pkgdir"
+
+ install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
+}