summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoffrey2018-06-15 14:21:25 +0000
committerJoffrey2018-06-15 14:21:25 +0000
commit378ae713cc175aee2f85ec9cbb075a63b151568c (patch)
tree0c98faefb7acaf17d66f9ce1e62b2b0d1bb53195
downloadaur-378ae713cc175aee2f85ec9cbb075a63b151568c.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD33
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..95ae5ad99e13
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = python-django-statici18n
+ pkgdesc = A Django app that provides helper for generating JavaScript catalog to static files
+ pkgver = 1.7.0
+ pkgrel = 1
+ url = https://github.com/zyegfryed/django-statici18n
+ arch = any
+ license = BSD
+ makedepends = python-setuptools
+ makedepends = python2-setuptools
+ source = https://github.com/zyegfryed/django-statici18n/archive/1.7.0.tar.gz
+ sha256sums = ea383a3fcaed09d6409b67b349525c20d647b70800a61cf4ff289ddf50e63458
+
+pkgname = python-django-statici18n
+ depends = python-django
+ depends = python-django-appconf
+
+pkgname = python2-django-statici18n
+ depends = python2-django
+ depends = python2-django-appconf
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5e567283893b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Joffrey <j-off@live.fr>
+
+pkgbase='python-django-statici18n'
+pkgname=('python-django-statici18n' 'python2-django-statici18n')
+pkgver='1.7.0'
+pkgrel=1
+pkgdesc='A Django app that provides helper for generating JavaScript catalog to static files'
+arch=('any')
+url='https://github.com/zyegfryed/django-statici18n'
+license=('BSD')
+makedepends=('python-setuptools' 'python2-setuptools')
+source=("https://github.com/zyegfryed/django-statici18n/archive/$pkgver.tar.gz")
+sha256sums=('ea383a3fcaed09d6409b67b349525c20d647b70800a61cf4ff289ddf50e63458')
+
+package_python-django-statici18n() {
+ depends=(
+ 'python-django'
+ 'python-django-appconf'
+ )
+ cd "$srcdir/django-statici18n-$pkgver"
+ install -Dm644 './LICENSE' "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ python './setup.py' install --root="$pkgdir" --optimize=1
+}
+
+package_python2-django-statici18n() {
+ depends=(
+ 'python2-django'
+ 'python2-django-appconf'
+ )
+ cd "$srcdir/django-statici18n-$pkgver"
+ install -Dm644 './LICENSE' "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ python2 './setup.py' install --root="$pkgdir" --optimize=1
+}