summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoffrey2020-02-23 15:19:23 +0000
committerJoffrey2020-02-23 15:19:23 +0000
commitf161bb4c9f71ce2c49639934c7838ccdf9971757 (patch)
tree9faddfb8122fba3f14bbbc5a55f2ab32623b2483
parent85d27f7df292940fc19093eae75848cdf7610a72 (diff)
downloadaur-f161bb4c9f71ce2c49639934c7838ccdf9971757.tar.gz
updpkg: 1.9.0
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD33
3 files changed, 21 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c3ffee45e484..1be9beeb76fa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,15 @@
pkgbase = python-django-statici18n
pkgdesc = A Django app that provides helper for generating JavaScript catalog to static files
- pkgver = 1.8.3
- pkgrel = 2
+ pkgver = 1.9.0
+ pkgrel = 1
url = https://github.com/zyegfryed/django-statici18n
arch = any
license = BSD
makedepends = python-setuptools
- makedepends = python2-setuptools
- source = https://github.com/zyegfryed/django-statici18n/archive/1.8.3.tar.gz
- sha256sums = 035d5ff092074e7fafbace7b51a94c90e0fc0292a867d5a82654dd4bb7bbdbd2
-
-pkgname = python-django-statici18n
depends = python-django
depends = python-django-appconf
+ source = python-django-statici18n-1.9.0.tar.gz::https://github.com/zyegfryed/django-statici18n/archive/v1.9.0.tar.gz
+ sha256sums = 5dfad9c3c6c75fcf4f90941aeb4745517da8ec16e8da7eeecb42d05dbe26155c
-pkgname = python2-django-statici18n
- depends = python2-django
- depends = python2-django-appconf
+pkgname = python-django-statici18n
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..7b4db42c16c2
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*.gz
+*.xz
+*.zip
+/pkg
+/src
diff --git a/PKGBUILD b/PKGBUILD
index a65d31ad1e7b..a2530d584231 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,22 @@
# Maintainer: Joffrey <j-off@live.fr>
-pkgbase='python-django-statici18n'
-pkgname=('python-django-statici18n' 'python2-django-statici18n')
-pkgver='1.8.3'
-pkgrel=2
+pkgname='python-django-statici18n'
+pkgver=1.9.0
+pkgrel=1
pkgdesc='A Django app that provides helper for generating JavaScript catalog to static files'
arch=('any')
url='https://github.com/zyegfryed/django-statici18n'
license=('BSD')
-makedepends=('python-setuptools' 'python2-setuptools')
-source=("https://github.com/zyegfryed/django-statici18n/archive/$pkgver.tar.gz")
-sha256sums=('035d5ff092074e7fafbace7b51a94c90e0fc0292a867d5a82654dd4bb7bbdbd2')
+depends=(
+ 'python-django'
+ 'python-django-appconf'
+)
+makedepends=('python-setuptools')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
+sha256sums=('5dfad9c3c6c75fcf4f90941aeb4745517da8ec16e8da7eeecb42d05dbe26155c')
-package_python-django-statici18n() {
- depends=(
- 'python-django'
- 'python-django-appconf'
- )
+package() {
cd "$srcdir/django-statici18n-$pkgver"
install -Dm644 './LICENSE' "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
python './setup.py' install --root="$pkgdir" --optimize=1
}
-
-package_python2-django-statici18n() {
- depends=(
- 'python2-django'
- 'python2-django-appconf'
- )
- cd "$srcdir/django-statici18n-$pkgver"
- install -Dm644 './LICENSE' "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
- python2 './setup.py' install --root="$pkgdir" --optimize=1
-}