summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin Azzam2017-10-18 14:47:35 +0200
committerKevin Azzam2017-11-14 16:31:26 +0100
commit1b5960df82c53b0ba328d5623116ca35df1f8705 (patch)
treebe16aaa0eeade38ac056874e3060682de0978db7
downloadaur-1b5960df82c53b0ba328d5623116ca35df1f8705.tar.gz
Initial commit - v1.2.17
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD29
3 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..87b61332aa07
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Tue Nov 14 15:30:29 UTC 2017
+pkgbase = python-django-storage-swift
+ pkgdesc = OpenStack Swift storage backend for Django
+ pkgver = 1.2.17
+ pkgrel = 1
+ url = https://github.com/dennisv/django-storage-swift/
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ makedepends = python-django
+ source = https://files.pythonhosted.org/packages/source/d/django-storage-swift/django-storage-swift-1.2.17.tar.gz
+ sha256sums = 6a51ebd39ca6dcfdbdabbc70e8842da9ed8db59dfe03b914aabdc2922bd2dd61
+
+pkgname = python-django-storage-swift
+ depends = python-django
+ depends = python-swiftclient
+ depends = python-magic
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..db550fe9498c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+*.tar.gz
+*.pkg.tar
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5f3afb71e1ba
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Kevin Azzam <aur@azz.am>
+
+_pipname=django-storage-swift
+pkgbase=python-django-storage-swift
+pkgname=('python-django-storage-swift')
+pkgver=1.2.17
+pkgrel=1
+pkgdesc="OpenStack Swift storage backend for Django"
+arch=('any')
+url="https://github.com/dennisv/django-storage-swift/"
+license=('MIT')
+makedepends=('python-setuptools' 'python-django')
+source=("https://files.pythonhosted.org/packages/source/d/django-storage-swift/django-storage-swift-${pkgver}.tar.gz")
+sha256sums=('6a51ebd39ca6dcfdbdabbc70e8842da9ed8db59dfe03b914aabdc2922bd2dd61')
+
+
+build() {
+ cd "${srcdir}/${_pipname}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ depends=('python-django' 'python-swiftclient' 'python-magic')
+
+ cd "${srcdir}/${_pipname}-${pkgver}"
+ python setup.py install --root="$pkgdir/" --optimize=1
+
+ # install -m644 "LICENSE.txt" "$pkgdir"/usr/share/licenses/$pkgname
+}