summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJeremy Audet2018-09-15 13:21:33 -0400
committerJeremy Audet2018-09-15 13:23:29 -0400
commit052b648091add574f01a21c71f8ff63b1a58ca08 (patch)
tree0ccadc0636d69bf5be834b327e4bd48379e96731
parent59a904c59dd43a9685c97dc7df09deb80d5f8f2a (diff)
downloadaur-052b648091add574f01a21c71f8ff63b1a58ca08.tar.gz
Update to version 2.0.1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD13
2 files changed, 8 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 58a8e5ace0b4..6b27eb1674e6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-django-tables2
pkgdesc = A module for rendering Django data sets as HTML tables.
- pkgver = 1.21.2
+ pkgver = 2.0.1
pkgrel = 1
url = https://github.com/bradleyayers/django-tables2
arch = any
@@ -8,8 +8,8 @@ pkgbase = python-django-tables2
makedepends = python-setuptools
makedepends = python2-setuptools
options = !emptydirs
- source = https://github.com/bradleyayers/django-tables2/archive/v1.21.2.tar.gz
- sha256sums = 5c0c85cefb4e39f969030c8517e11180f239c64f7630a0e34ac8ef0d4ffc636a
+ source = https://github.com/bradleyayers/django-tables2/archive/v2.0.1.tar.gz
+ sha256sums = faef491a9332c693316afb27d97191336fd673614a812ee6fdd32c47e581305e
pkgname = python-django-tables2
depends = python-django>=1.11
diff --git a/PKGBUILD b/PKGBUILD
index fb1f89f60164..9eab3d4bf688 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,8 @@
# Maintainer: Jeremy Audet <jerebear@protonmail.com>
-#
-# namcap incorrectly states that python{,2}-{django,six} are unnecessary deps.
pkgbase=python-django-tables2
-_pkgbase="${pkgbase#python-}"
pkgname=(python-django-tables2 python2-django-tables2)
-pkgver=1.21.2
+pkgver=2.0.1
pkgrel=1
pkgdesc='A module for rendering Django data sets as HTML tables.'
arch=(any)
@@ -13,13 +10,13 @@ url='https://github.com/bradleyayers/django-tables2'
license=(MIT)
options=(!emptydirs)
makedepends=(python-setuptools python2-setuptools)
-source=("https://github.com/bradleyayers/${_pkgbase}/archive/v${pkgver}.tar.gz")
-sha256sums=('5c0c85cefb4e39f969030c8517e11180f239c64f7630a0e34ac8ef0d4ffc636a')
+source=("https://github.com/bradleyayers/django-tables2/archive/v${pkgver}.tar.gz")
+sha256sums=('faef491a9332c693316afb27d97191336fd673614a812ee6fdd32c47e581305e')
package_python-django-tables2() {
depends=('python-django>=1.11')
optdepends=('python-tablib: to export table data as CSV, XLS, etc.')
- cd "${srcdir}/${_pkgbase}-${pkgver}"
+ cd "${srcdir}/django-tables2-${pkgver}"
python setup.py install --root="${pkgdir}/" --optimize=1
install -Dm 644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
@@ -27,7 +24,7 @@ package_python-django-tables2() {
package_python2-django-tables2() {
depends=('python2-django>=1.11')
optdepends=('python2-tablib: to export table data as CSV, XLS, etc.')
- cd "${srcdir}/${_pkgbase}-${pkgver}"
+ cd "${srcdir}/django-tables2-${pkgver}"
python2 setup.py install --root="${pkgdir}/" --optimize=1
install -Dm 644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}