summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJeremy Audet2020-04-05 13:05:10 -0400
committerJeremy Audet2020-04-05 13:05:10 -0400
commit300888e6ee4e5d80be22f878bc2c6e65b4dd8143 (patch)
treefd44f93dca4ed3a3c58d775df5b070f36d3b6c34
parent5dbd55a5e422e9f409cc258e634259f22bae9a28 (diff)
downloadaur-300888e6ee4e5d80be22f878bc2c6e65b4dd8143.tar.gz
Drop support for Python 2
Upstream dropped support in version 2.1.0, on 2019-07-22. See: https://github.com/jieter/django-tables2/blob/master/CHANGELOG.md#210-2019-07-22
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD19
2 files changed, 7 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index edbfc6d6c2c6..53aa370e94bb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,16 +6,11 @@ pkgbase = python-django-tables2
arch = any
license = MIT
makedepends = python-setuptools
- makedepends = python2-setuptools
+ depends = python-django>=1.11
+ optdepends = python-tablib: to export table data as CSV, XLS, etc.
options = !emptydirs
source = https://github.com/bradleyayers/django-tables2/archive/v2.2.1.tar.gz
sha256sums = ec0112ebebda943fee141ab836a336ec74120214a576bbf4e9ffb584888674f9
pkgname = python-django-tables2
- depends = python-django>=1.11
- optdepends = python-tablib: to export table data as CSV, XLS, etc.
-
-pkgname = python2-django-tables2
- depends = python2-django>=1.11
- optdepends = python2-tablib: to export table data as CSV, XLS, etc.
diff --git a/PKGBUILD b/PKGBUILD
index a0585a6e10de..f94f9c823277 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,6 @@
# Maintainer: Jeremy Audet <jerebear@protonmail.com>
-pkgbase=python-django-tables2
-pkgname=(python-django-tables2 python2-django-tables2)
+pkgname=python-django-tables2
pkgver=2.2.1
pkgrel=1
pkgdesc='A module for rendering Django data sets as HTML tables.'
@@ -9,24 +8,16 @@ arch=(any)
url='https://github.com/bradleyayers/django-tables2'
license=(MIT)
options=(!emptydirs)
-makedepends=(python-setuptools python2-setuptools)
+depends=('python-django>=1.11')
+makedepends=(python-setuptools)
+optdepends=('python-tablib: to export table data as CSV, XLS, etc.')
source=("https://github.com/bradleyayers/django-tables2/archive/v${pkgver}.tar.gz")
sha256sums=('ec0112ebebda943fee141ab836a336ec74120214a576bbf4e9ffb584888674f9')
-package_python-django-tables2() {
- depends=('python-django>=1.11')
- optdepends=('python-tablib: to export table data as CSV, XLS, etc.')
+package() {
cd "${srcdir}/django-tables2-${pkgver}"
python setup.py install --root="${pkgdir}/" --optimize=1
install -Dm 644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
-package_python2-django-tables2() {
- depends=('python2-django>=1.11')
- optdepends=('python2-tablib: to export table data as CSV, XLS, etc.')
- cd "${srcdir}/django-tables2-${pkgver}"
- python2 setup.py install --root="${pkgdir}/" --optimize=1
- install -Dm 644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
-}
-
# vim:set ts=2 sw=2 et: