summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJeremy Audet2016-06-05 15:46:26 -0400
committerJeremy Audet2016-06-05 15:46:26 -0400
commit93a7774bf3446cdfc458ac452b37e39b15fdf6fa (patch)
tree21555e5996868fd2c6d05de9dd75fc5ef80a552e
parent3769cb695744d3bffcc4463f44f0e5c1e1db2a3c (diff)
downloadaur-93a7774bf3446cdfc458ac452b37e39b15fdf6fa.tar.gz
Update to version 1.2.2
In addition, update the list of dependencies so that python{,2}-django has a minimum required version. This matches what is listed in the source's `setup.py` file.
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD12
2 files changed, 14 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 460c25917992..911424929b95 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,23 @@
# Generated by mksrcinfo v8
-# Fri May 13 02:06:18 UTC 2016
+# Sun Jun 5 19:45:24 UTC 2016
pkgbase = python-django-tables2
pkgdesc = A module for rendering Django data sets as HTML tables.
- pkgver = 1.2.1
+ pkgver = 1.2.2
pkgrel = 1
url = https://github.com/bradleyayers/django-tables2
arch = any
license = MIT
- makedepends = python-django
+ makedepends = python-django>=1.8
makedepends = python-setuptools
- makedepends = python2-django
+ makedepends = python2-django>=1.8
makedepends = python2-setuptools
options = !emptydirs
- source = https://github.com/bradleyayers/django-tables2/archive/v1.2.1.tar.gz
- sha256sums = 8f0828353668dfd8feb295817eff009bd96856ff6acf1dd2b312b7f4e4da4d4d
+ source = https://github.com/bradleyayers/django-tables2/archive/v1.2.2.tar.gz
+ sha256sums = 5dd0e685a5f9c4980d5d5d6060b0493dcea51031c1dea5526fa5a389e06f7968
pkgname = python-django-tables2
- depends = python-django
+ depends = python-django>=1.8
pkgname = python2-django-tables2
- depends = python2-django
+ depends = python2-django>=1.8
diff --git a/PKGBUILD b/PKGBUILD
index 54201fa1ad2b..513839e65165 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,31 +5,31 @@
pkgbase=python-django-tables2
_pkgbase="${pkgbase#python-}"
pkgname=(python-django-tables2 python2-django-tables2)
-pkgver=1.2.1
+pkgver=1.2.2
pkgrel=1
pkgdesc='A module for rendering Django data sets as HTML tables.'
arch=(any)
url='https://github.com/bradleyayers/django-tables2'
license=(MIT)
makedepends=(
- python-django
+ 'python-django>=1.8'
python-setuptools
- python2-django
+ 'python2-django>=1.8'
python2-setuptools
)
options=(!emptydirs)
source=("https://github.com/bradleyayers/${_pkgbase}/archive/v${pkgver}.tar.gz")
-sha256sums=('8f0828353668dfd8feb295817eff009bd96856ff6acf1dd2b312b7f4e4da4d4d')
+sha256sums=('5dd0e685a5f9c4980d5d5d6060b0493dcea51031c1dea5526fa5a389e06f7968')
package_python-django-tables2() {
- depends=(python-django)
+ depends=('python-django>=1.8')
cd "${srcdir}/${_pkgbase}-${pkgver}"
python setup.py install --root="${pkgdir}/" --optimize=1
install -Dm 644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
package_python2-django-tables2() {
- depends=(python2-django)
+ depends=('python2-django>=1.8')
cd "${srcdir}/${_pkgbase}-${pkgver}"
python2 setup.py install --root="${pkgdir}/" --optimize=1
install -Dm 644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"