summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJeremy Audet2016-05-03 09:46:32 -0400
committerJeremy Audet2016-05-03 09:46:32 -0400
commitd87d33fd19eb74efd7f146c3c0a93b7f0993241a (patch)
tree8d110289032f38fb4660a9033e6aa1793aa21a67
parentd03918504ec5d20d87c08dcef7717af223d5297e (diff)
downloadaur-d87d33fd19eb74efd7f146c3c0a93b7f0993241a.tar.gz
Update to v1.2.0, drop unneeded dependency
Drop python-six from the list of dependencies. It is no longer listed in the `install_requires` argument in `setup.py`, and an inspection of the source code shows that django-tables2 uses the the version of six bundled with django.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
2 files changed, 3 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 395ef76a173f..0b61a376a30a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Mon Apr 18 12:57:20 UTC 2016
+# Tue May 3 13:45:46 UTC 2016
pkgbase = python-django-tables2
pkgdesc = A module for rendering Django data sets as HTML tables.
pkgver = 1.1.6
@@ -9,19 +9,15 @@ pkgbase = python-django-tables2
license = MIT
makedepends = python-django
makedepends = python-setuptools
- makedepends = python-six
makedepends = python2-django
makedepends = python2-setuptools
- makedepends = python2-six
options = !emptydirs
source = https://github.com/bradleyayers/django-tables2/archive/v1.1.6.tar.gz
sha256sums = b54cb1eea10aef1c9f0601f80ca58fb0db919dd80ae281797fd9c7933eb34391
pkgname = python-django-tables2
depends = python-django
- depends = python-six
pkgname = python2-django-tables2
depends = python2-django
- depends = python2-six
diff --git a/PKGBUILD b/PKGBUILD
index 9e45378d24f0..068d93aabce1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,24 +14,22 @@ license=(MIT)
makedepends=(
python-django
python-setuptools
- python-six
python2-django
python2-setuptools
- python2-six
)
options=(!emptydirs)
source=("https://github.com/bradleyayers/${_pkgbase}/archive/v${pkgver}.tar.gz")
sha256sums=('b54cb1eea10aef1c9f0601f80ca58fb0db919dd80ae281797fd9c7933eb34391')
package_python-django-tables2() {
- depends=(python-django python-six)
+ depends=(python-django)
cd "${srcdir}/${_pkgbase}-${pkgver}"
python setup.py install --root="${pkgdir}/" --optimize=1
install -Dm 644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
package_python2-django-tables2() {
- depends=(python2-django python2-six)
+ depends=(python2-django)
cd "${srcdir}/${_pkgbase}-${pkgver}"
python2 setup.py install --root="${pkgdir}/" --optimize=1
install -Dm 644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"