summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJaroslav Lichtblau2018-10-26 19:34:43 +0200
committerJaroslav Lichtblau2018-10-26 19:34:43 +0200
commitbcb755ff18646f61a8d299cb7be15709b610d1cf (patch)
treefb418afafecf088127881176c34636b20bf76d50
parentdf927024eaaa5090d52eaf40fcce83ede905ee4c (diff)
downloadaur-bcb755ff18646f61a8d299cb7be15709b610d1cf.tar.gz
python-django-taggit-0.23.0-1
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD23
2 files changed, 18 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index db7f0c59aedb..13100d61156c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,18 @@
# Generated by mksrcinfo v8
-# Sun Feb 28 08:12:39 UTC 2016
+# Fri Oct 26 17:34:41 UTC 2018
pkgbase = python-django-taggit
pkgdesc = Simple tagging application for Django
- pkgver = 0.18.0
+ pkgver = 0.23.0
pkgrel = 1
url = http://github.com/alex/django-taggit/
arch = any
license = BSD
makedepends = python2-django
makedepends = python-django
- source = http://pypi.python.org/packages/source/d/django-taggit/django-taggit-0.18.0.tar.gz
- md5sums = 93c2cef739334a4ae47414926b0d0965
+ makedepends = python2-mock
+ makedepends = python-mock
+ source = django-taggit-0.23.0.tar.gz::https://github.com/alex/django-taggit/archive/0.23.0.tar.gz
+ sha256sums = f6c9cbeea93dd04406f815ebfea3bdfb4fab0af5e1a93d2f3e13a79e0b47486a
pkgname = python-django-taggit
depends = python-django
diff --git a/PKGBUILD b/PKGBUILD
index 7f5b0e279ec7..47d8ee26704a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,22 +3,23 @@
pkgbase=python-django-taggit
pkgname=(python-django-taggit python2-django-taggit)
_pkgname=django-taggit
-pkgver=0.18.0
+pkgver=0.23.0
pkgrel=1
pkgdesc="Simple tagging application for Django"
arch=('any')
url="http://github.com/alex/django-taggit/"
license=('BSD')
-makedepends=('python2-django' 'python-django')
-source=(http://pypi.python.org/packages/source/d/$_pkgname/$_pkgname-$pkgver.tar.gz)
-md5sums=('93c2cef739334a4ae47414926b0d0965')
-
-check() {
- cd "${srcdir}"/$_pkgname-$pkgver
-
- python2 runtests.py
- python runtests.py
-}
+makedepends=('python2-django' 'python-django' 'python2-mock' 'python-mock')
+source=($_pkgname-$pkgver.tar.gz::https://github.com/alex/django-taggit/archive/$pkgver.tar.gz)
+sha256sums=('f6c9cbeea93dd04406f815ebfea3bdfb4fab0af5e1a93d2f3e13a79e0b47486a')
+
+# tests currently fail
+# check() {
+# cd "${srcdir}"/$_pkgname-$pkgver
+#
+# python2 setup.py test
+# python setup.py test
+# }
package_python2-django-taggit() {
depends=('python2-django')