summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgetzze2018-06-03 22:55:52 +0100
committergetzze2018-06-03 22:55:52 +0100
commit9ddc2bd58757e7a8ed2d896c66f5bab6124c1b00 (patch)
tree572e8831c5514c418010cd9548217447f3ea8408
downloadaur-9ddc2bd58757e7a8ed2d896c66f5bab6124c1b00.tar.gz
Initial commit version 1.9
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD32
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..de7e771400d5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = python-django-versatile-imagefield
+ pkgdesc = Drop-in replacement for django's ImageField, provides a flexible, intuitive and easily-extensible interface
+ pkgver = 1.9
+ pkgrel = 1
+ url = https://github.com/respondcreate/django-versatileimagefield
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ makedepends = python2-setuptools
+ options = !emptydirs
+ source = python-django-versatile-imagefield-1.9.tar.gz::https://github.com/respondcreate/django-versatileimagefield/archive/1.9.tar.gz
+ sha256sums = 07b0c6eb2d6c95b08ac5e4c471d500a9bb409f29194876bc84c3607c4299a8b4
+
+pkgname = python-django-versatile-imagefield
+ depends = python-django
+ depends = python-pillow
+ depends = python-django-rest-framework
+
+pkgname = python2-django-versatile-imagefield
+ depends = python2-django
+ depends = python2-pillow
+ depends = python2-django-rest-framework
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b2a0f5a595f1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: getzze <getzze at gmail dot com>
+
+pkgname=('python-django-versatile-imagefield' 'python2-django-versatile-imagefield')
+pkgver=1.9
+pkgrel=1
+pkgdesc="Drop-in replacement for django's ImageField, provides a flexible, intuitive and easily-extensible interface"
+arch=(any)
+url="https://github.com/respondcreate/django-versatileimagefield"
+license=('MIT')
+options=(!emptydirs)
+source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz")
+sha256sums=('07b0c6eb2d6c95b08ac5e4c471d500a9bb409f29194876bc84c3607c4299a8b4')
+makedepends=('python-setuptools' 'python2-setuptools')
+
+prepare() {
+ cd "$srcdir/django-versatileimagefield-$pkgver"
+ rm -rf tests
+}
+
+package_python-django-versatile-imagefield() {
+ depends=('python-django' 'python-pillow' 'python-django-rest-framework')
+ cd "$srcdir/django-versatileimagefield-$pkgver"
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}
+
+package_python2-django-versatile-imagefield() {
+ depends=('python2-django' 'python2-pillow' 'python2-django-rest-framework')
+ cd "$srcdir/django-versatileimagefield-$pkgver"
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+}