summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzhang.j.k2021-01-24 21:12:50 +0800
committerzhang.j.k2021-01-24 21:12:50 +0800
commit932037d72bd1a677170590ebb05d8e9de427e4c4 (patch)
tree1d9b30887f287772600da0c52a8d84966b87bc20
downloadaur-932037d72bd1a677170590ebb05d8e9de427e4c4.tar.gz
init djangorestframework-xml
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore22
-rw-r--r--PKGBUILD26
3 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7cd02874cd36
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-djangorestframework-xml
+ pkgdesc = XML support for Django REST Framework
+ pkgver = 2.0.0
+ pkgrel = 1
+ url = https://github.com/jpadilla/django-rest-framework-xml
+ arch = any
+ license = BSD
+ makedepends = python-setuptools
+ depends = python
+ source = https://files.pythonhosted.org/packages/source/d/djangorestframework-xml/djangorestframework-xml-2.0.0.tar.gz
+ sha256sums = 35f6c811d0ab8c8466b26db234e16a2ed32d76381715257aebf4c7be2c202ca1
+
+pkgname = python-djangorestframework-xml
+ depends = python
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..17af2490905a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,22 @@
+*.tar.zst
+python-django-rest-polymorphic/
+pkg/
+src/
+
+# ignore everything
+*
+!.gitignore
+
+# except PKGBUILD needed files
+!PKGBUILD
+!.SRCINFO
+!*.install
+!ChangeLog
+
+# common wing-man files
+!*.diff
+!*.patch
+
+!README.md
+
+# add files that don't have an online source \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fddab06cf948
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Zhang.j.k <zhangjk67 at gmail dian com>
+
+pkgbase='python-djangorestframework-xml'
+pkgname=('python-djangorestframework-xml')
+_module='djangorestframework-xml'
+pkgver='2.0.0'
+pkgrel=1
+pkgdesc="XML support for Django REST Framework"
+url="https://github.com/jpadilla/django-rest-framework-xml"
+depends=('python')
+makedepends=('python-setuptools')
+license=('BSD')
+arch=('any')
+source=("https://files.pythonhosted.org/packages/source/${_module::1}/$_module/$_module-$pkgver.tar.gz")
+sha256sums=('35f6c811d0ab8c8466b26db234e16a2ed32d76381715257aebf4c7be2c202ca1')
+
+build() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ depends+=()
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}