summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoracxz2023-02-28 14:23:44 -0600
committeracxz2023-02-28 14:23:44 -0600
commit23f42981667da80d7326bb38a5a3cfc05485be24 (patch)
tree8c471b8dd6f92cf9c9b8644da98241590544dc07
parent8c8cfd4983f3a128c05791d602bba7fd0f9ccaa8 (diff)
downloadaur-23f42981667da80d7326bb38a5a3cfc05485be24.tar.gz
upgpkg: python-dm-tree 0.1.8-1
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD12
2 files changed, 12 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3683fbe4f4ee..831ee89df3b7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,20 @@
pkgbase = python-dm-tree
pkgdesc = tree is a library for working with nested data structures
- pkgver = 0.1.7
+ pkgver = 0.1.8
pkgrel = 1
url = https://tree.readthedocs.io
arch = any
license = Apache-2.0
makedepends = python
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
makedepends = python-setuptools
makedepends = cmake
makedepends = git
depends = python
depends = python-six
- source = python-dm-tree-0.1.7::https://pypi.org/packages/source/d/dm-tree/dm-tree-0.1.7.tar.gz
- sha256sums = 30fec8aca5b92823c0e796a2f33b875b4dccd470b57e91e6c542405c5f77fd2a
+ source = python-dm-tree-0.1.8::https://pypi.org/packages/source/d/dm-tree/dm-tree-0.1.8.tar.gz
+ sha256sums = 0fcaabbb14e7980377439e7140bd05552739ca5e515ecb3119f234acee4b9430
pkgname = python-dm-tree
diff --git a/PKGBUILD b/PKGBUILD
index cad74569234c..b887ecc62fda 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,26 @@
# Maintainer: acxz <akashpatel2008 at yahoo dot com>
pkgname=python-dm-tree
-pkgver=0.1.7
+pkgver=0.1.8
pkgrel=1
pkgdesc='tree is a library for working with nested data structures'
arch=('any')
url='https://tree.readthedocs.io'
license=('Apache-2.0')
depends=(python python-six)
-optdepends=()
-makedepends=(python python-setuptools cmake git)
+makedepends=(python python-build python-installer python-wheel python-setuptools
+ cmake git)
source=("$pkgname-$pkgver::https://pypi.org/packages/source/d/dm-tree/dm-tree-${pkgver}.tar.gz")
-sha256sums=('30fec8aca5b92823c0e796a2f33b875b4dccd470b57e91e6c542405c5f77fd2a')
+sha256sums=('0fcaabbb14e7980377439e7140bd05552739ca5e515ecb3119f234acee4b9430')
_pkgname=dm-tree
build() {
cd "${srcdir}/${_pkgname}-${pkgver}"
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd "${srcdir}/${_pkgname}-${pkgver}"
- python setup.py install --root="$pkgdir"/ --optimize=1
+ python -m installer --destdir="$pkgdir" dist/*.whl
}