summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoracxz2020-03-26 00:09:00 -0400
committeracxz2020-03-26 00:09:00 -0400
commit649efc2448aaaaed76de6f36bd4911eefdd8864f (patch)
treecd543fe4f082a192dffba1be44deec7f3b01b2dd
downloadaur-649efc2448aaaaed76de6f36bd4911eefdd8864f.tar.gz
create python-dm-tree package
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD26
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..81ef7830df91
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-dm-tree
+ pkgdesc = tree is a library for working with nested data structures
+ pkgver = 0.1.1
+ pkgrel = 1
+ url = https://tree.readthedocs.io
+ arch = any
+ license = Apache-2.0
+ makedepends = python
+ makedepends = python-setuptools
+ depends = python
+ depends = python-six
+ source = python-dm-tree-0.1.1::https://github.com/deepmind/tree/archive/0.1.1.tar.gz
+ sha256sums = f326e1c450a7d3cfd42288c2a1a0ef1cfb2bfa576f7f936d50a1fa144942e0a1
+
+pkgname = python-dm-tree
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4a599ff63707
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: acxz <akashpatel2008 at yahoo dot com>
+
+pkgname=python-dm-tree
+pkgver=0.1.1
+pkgrel=1
+pkgdesc='tree is a library for working with nested data structures'
+arch=('any')
+url='https://tree.readthedocs.io'
+license=('Apache-2.0')
+depends=(python python-six)
+optdepends=()
+makedepends=(python python-setuptools)
+source=("$pkgname-$pkgver::https://github.com/deepmind/tree/archive/$pkgver.tar.gz")
+sha256sums=('f326e1c450a7d3cfd42288c2a1a0ef1cfb2bfa576f7f936d50a1fa144942e0a1')
+
+_pkgname=tree
+
+build() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ python setup.py install --root="$pkgdir"/ --optimize=1
+}