summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPumpkinCheshire2021-03-05 17:18:14 +0800
committerPumpkinCheshire2021-03-05 17:18:14 +0800
commit942f8369b7ca42ca07082efb4d2326167b5ca4e6 (patch)
treece9f0857aaa75ab0241acbdbdda0c4a718590a72
downloadaur-942f8369b7ca42ca07082efb4d2326167b5ca4e6.tar.gz
init
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD27
3 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..83e5c0f951af
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python-dmsh
+ pkgdesc = Simple mesh generator inspired by distmesh.
+ pkgver = 0.2.11
+ pkgrel = 1
+ url = https://github.com/nschloe/optimesh
+ arch = any
+ license = GPL
+ makedepends = python
+ makedepends = python-setuptools
+ depends = python-meshplex
+ depends = python-numpy
+ depends = python-scipy
+ optdepends = python-matplotlib
+ source = https://files.pythonhosted.org/packages/source/d/dmsh/dmsh-0.2.11.tar.gz
+ sha256sums = 42dcd07fd597d73ce4b33cdc8b5410af92ead22f5d1e721c7107f083d1710e60
+
+pkgname = python-dmsh
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..018a3de08144
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!PKGBUILD
+!.SRCINFO
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b174854ce60c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: PumpkinCheshire <sollyonzou at gmail dot com>
+
+pkgname=python-dmsh
+_name=dmsh
+pkgver=0.2.11
+pkgrel=1
+pkgdesc="Simple mesh generator inspired by distmesh."
+arch=('any')
+url="https://github.com/nschloe/optimesh"
+license=('GPL')
+optdepends=('python-matplotlib')
+makedepends=('python'
+ 'python-setuptools')
+depends=('python-meshplex' 'python-numpy' 'python-scipy')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
+sha256sums=('42dcd07fd597d73ce4b33cdc8b5410af92ead22f5d1e721c7107f083d1710e60')
+
+build() {
+ cd "$srcdir/$_name-$pkgver"
+ python -c "from setuptools import setup; setup()" build
+}
+
+package() {
+ cd "$srcdir/$_name-$pkgver"
+ python -c "from setuptools import setup; setup();" install --root="$pkgdir/" --optimize=1 --skip-build
+ install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
+}