summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTomas Krizek2020-07-14 12:52:59 +0200
committerTomas Krizek2020-07-14 13:08:30 +0200
commit9493813ffb307b36f75360ec8350a367515a5200 (patch)
treea78aebe7c2d516e0fca295af659c92e3a51c7129
downloadaur-9493813ffb307b36f75360ec8350a367515a5200.tar.gz
dnspython 2.0.0rc2
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD38
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7e95abe257d4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = python-dnspython-git
+ pkgdesc = A DNS toolkit for Python
+ pkgver = 2.0.0rc2
+ pkgrel = 1
+ url = http://www.dnspython.org
+ arch = any
+ license = ISC
+ makedepends = python-setuptools
+ depends = python
+ optdepends = python-idna: support for update IDNA 2008
+ optdepends = python-cryptography: DNSSEC support
+ optdepends = python-requests: DNS-over-HTTPS support
+ optdepends = python-requests-toolbelt: DNS-over-HTTPS support
+ optdepends = python-trio: asyc I/O backend
+ optdepends = python-curio: async I/O backend
+ optdepends = python-sniffio: async I/O
+ source = https://github.com/rthalley/dnspython/archive/v2.0.0rc2.tar.gz
+ sha256sums = c588b132eefaf7d0892a3b0aa863b990264f08811ae4b0d4d6e6b62086c3de18
+
+pkgname = python-dnspython-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2a32d9294e6d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Tomas Krizek <tomas.krizek@nic.cz>
+
+pkgname=python-dnspython-git
+pkgver=2.0.0rc2
+pkgrel=1
+pkgdesc="A DNS toolkit for Python"
+arch=('any')
+url="http://www.dnspython.org"
+license=('ISC')
+makedepends=(
+ 'python-setuptools'
+ # 'cython' # uncomment dep & build option for cython optimization speedup
+)
+depends=('python')
+optdepends=(
+ 'python-idna: support for update IDNA 2008'
+ 'python-cryptography: DNSSEC support'
+ 'python-requests: DNS-over-HTTPS support'
+ 'python-requests-toolbelt: DNS-over-HTTPS support'
+ 'python-trio: asyc I/O backend'
+ 'python-curio: async I/O backend'
+ 'python-sniffio: async I/O'
+)
+source=("https://github.com/rthalley/dnspython/archive/v${pkgver}.tar.gz")
+sha256sums=('c588b132eefaf7d0892a3b0aa863b990264f08811ae4b0d4d6e6b62086c3de18')
+
+build() {
+ cd "${srcdir}"/dnspython-${pkgver}
+
+ python setup.py build # --cython-compile
+}
+
+package() {
+ cd "${srcdir}"/dnspython-${pkgver}
+
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ install -Dm644 LICENSE "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
+}