summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin Puertas2022-08-05 19:50:06 +0200
committerKevin Puertas2022-08-05 19:50:06 +0200
commit5e7e77e01c3de0c452acf8d226b4d02a0f16d7cb (patch)
tree42421a114631113a31b213b89cbdd7fce672c972
downloadaur-5e7e77e01c3de0c452acf8d226b4d02a0f16d7cb.tar.gz
Version 1.1.2
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD25
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0417224e96ff
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-dnsrecon
+ pkgdesc = A DNS Enumeration and Scanning tool in Python
+ pkgver = 1.1.2
+ pkgrel = 1
+ url = https://github.com/darkoperator/dnsrecon
+ arch = any
+ license = GNU General Public License v2.0
+ makedepends = python-setuptools
+ depends = python
+ depends = python-netaddr
+ source = python-dnsrecon-1.1.2.tar.gz::https://github.com/darkoperator/dnsrecon/archive/1.1.2.tar.gz
+ sha256sums = 2edb6435350dea05579a22635deb02719523a3389cc190dd61de310b4c9c5e86
+
+pkgname = python-dnsrecon
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6aa3be9b5d15
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Kevin Puertas <kevinpr@jkanetwork.com>
+
+_name=dnsrecon
+pkgname=python-dnsrecon
+pkgver=1.1.2
+pkgrel=1
+pkgdesc='A DNS Enumeration and Scanning tool in Python'
+arch=(any)
+url="https://github.com/darkoperator/dnsrecon"
+license=('GNU General Public License v2.0')
+depends=('python' 'python-netaddr')
+makedepends=(python-setuptools)
+source=($pkgname-$pkgver.tar.gz::"https://github.com/darkoperator/$_name/archive/$pkgver.tar.gz")
+sha256sums=('2edb6435350dea05579a22635deb02719523a3389cc190dd61de310b4c9c5e86')
+
+build() {
+ cd $_name-$pkgver
+ python setup.py build
+}
+
+package(){
+ cd $_name-$pkgver
+ python setup.py install --root="$pkgdir" --optimize=1
+ install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}