summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndré Klitzing2015-09-17 11:29:27 +0200
committerAndré Klitzing2015-09-17 11:29:27 +0200
commit51910a60ced02d6cea662a570d5f1a63ee8e667b (patch)
tree2962facdb1ded7f0a77d7acee5be8e9b54f33591
downloadaur-51910a60ced02d6cea662a570d5f1a63ee8e667b.tar.gz
Add initial PKGBUILD for doc8
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore9
-rw-r--r--PKGBUILD37
3 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cd471ebe0f1b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-doc8
+ pkgdesc = Style checker for Sphinx (or other) RST documentation
+ pkgver = 0.6.0
+ pkgrel = 1
+ url = https://pypi.python.org/pypi/doc8
+ arch = any
+ license = Apache 2.0
+ makedepends = python-setuptools
+ makedepends = python2-setuptools
+ source = https://pypi.python.org/packages/source/d/doc8/doc8-0.6.0.tar.gz
+ sha256sums = 42ccb69e9240546afec6cdae00b134592942b8b135d7017a748fd5af41e2d590
+
+pkgname = python-doc8
+
+pkgname = python2-doc8
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..ce9c71dbce23
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,9 @@
+*.src.tar.*
+*.pkg.tar.*
+*.orig
+*.rej
+*.swp
+*.part
+*.tar.gz
+src
+pkg
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c916fd0a7951
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+pkgbase=python-doc8
+pkgname=(python-doc8 python2-doc8)
+_pyname=doc8
+pkgver=0.6.0
+pkgrel=1
+arch=(any)
+pkgdesc="Style checker for Sphinx (or other) RST documentation"
+url='https://pypi.python.org/pypi/doc8'
+license=('Apache 2.0')
+makedepends=(python-setuptools python2-setuptools)
+source=("https://pypi.python.org/packages/source/d/${_pyname}/${_pyname}-${pkgver}.tar.gz")
+sha256sums=('42ccb69e9240546afec6cdae00b134592942b8b135d7017a748fd5af41e2d590')
+
+build() {
+ cp -r $_pyname-$pkgver $_pyname-$pkgver-py2
+
+ cd $_pyname-$pkgver
+ python setup.py build
+
+ cd "$srcdir"/$_pyname-$pkgver-py2
+ python2 setup.py build
+}
+
+package_python-doc8() {
+ cd $_pyname-${pkgver}
+ python setup.py install --root="$pkgdir" --optimize=1
+
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}
+
+package_python2-doc8() {
+ cd $_pyname-${pkgver}-py2
+ python2 setup.py install --root="$pkgdir" --optimize=1
+
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}
+