summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndré Klitzing2015-09-17 11:49:40 +0200
committerAndré Klitzing2015-09-17 11:49:40 +0200
commit58cff9a104b42b73d6633ba1027dc29df6ae84bd (patch)
tree3fb3ea7fe928c7a30d66be3acf90bfc590c02860
parent5ad17a99f3544e864077f8bef13babf271a320f2 (diff)
downloadaur-58cff9a104b42b73d6633ba1027dc29df6ae84bd.tar.gz
Add python-restructuredtext_lint
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
2 files changed, 6 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7aecb946025a..68f1918008d3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-doc8
pkgdesc = Style checker for Sphinx (or other) RST documentation
pkgver = 0.6.0
- pkgrel = 1
+ pkgrel = 2
url = https://pypi.python.org/pypi/doc8
arch = any
license = Apache 2.0
@@ -16,6 +16,7 @@ pkgname = python-doc8
depends = python-docutils
depends = python-argparse
depends = python-six
+ depends = python-restructuredtext_lint
pkgname = python2-doc8
depends = python2-stevedore
@@ -23,4 +24,5 @@ pkgname = python2-doc8
depends = python2-docutils
depends = python2-argparse
depends = python2-six
+ depends = python2-restructuredtext_lint
diff --git a/PKGBUILD b/PKGBUILD
index 6e54b8bbbfe9..a7e1e3d8f05d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@ pkgbase=python-doc8
pkgname=(python-doc8 python2-doc8)
_pyname=doc8
pkgver=0.6.0
-pkgrel=1
+pkgrel=2
arch=(any)
pkgdesc="Style checker for Sphinx (or other) RST documentation"
url='https://pypi.python.org/pypi/doc8'
@@ -22,7 +22,7 @@ build() {
}
package_python-doc8() {
- depends=('python-stevedore' 'python-chardet' 'python-docutils' 'python-argparse' 'python-six')
+ depends=('python-stevedore' 'python-chardet' 'python-docutils' 'python-argparse' 'python-six' 'python-restructuredtext_lint')
cd $_pyname-${pkgver}
python setup.py install --root="$pkgdir" --optimize=1
@@ -30,7 +30,7 @@ package_python-doc8() {
}
package_python2-doc8() {
- depends=('python2-stevedore' 'python2-chardet' 'python2-docutils' 'python2-argparse' 'python2-six')
+ depends=('python2-stevedore' 'python2-chardet' 'python2-docutils' 'python2-argparse' 'python2-six' 'python2-restructuredtext_lint')
cd $_pyname-${pkgver}-py2
python2 setup.py install --root="$pkgdir" --optimize=1