summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bershatsky2024-04-18 11:13:11 +0300
committerDaniel Bershatsky2024-04-18 11:13:11 +0300
commit59de195a2e78a89476d68f4ac4febdc1fac0e149 (patch)
treefbeab64d8cff66951c697d3c25e3c6078094775c
downloadaur-59de195a2e78a89476d68f4ac4febdc1fac0e149.tar.gz
Bootstrap from 0.4.0 release
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD36
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e5bf2ad2a7cb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python-docker-pycreds
+ pkgdesc = Python bindings for the docker credentials store API Resources
+ pkgver = 0.4.0
+ pkgrel = 1
+ url = https://github.com/shin-/dockerpy-creds
+ arch = any
+ license = Apache
+ checkdepends = flake8
+ checkdepends = python-pytest
+ checkdepends = python-pytest-cov
+ makedepends = python-build
+ makedepends = python-installer
+ depends = python-six
+ source = python-docker-pycreds-0.4.0.tar.gz::https://github.com/shin-/dockerpy-creds/archive/refs/tags/0.4.0.tar.gz
+ sha256sums = c76c2863c6e9a31b8f70ee5b8b0e5ac6860bfd422d930c04a387599e4272b4b9
+
+pkgname = python-docker-pycreds
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..72fee251889e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Daniel Bershatsky <bepshatsky@yandex.ru>
+
+pkgname=python-docker-pycreds
+_pkgname=${pkgname#python-}
+pkgver=0.4.0
+pkgrel=1
+pkgdesc='Python bindings for the docker credentials store API Resources'
+arch=('any')
+url='https://github.com/shin-/dockerpy-creds'
+license=('Apache')
+groups=()
+depends=('python-six')
+makedepends=('python-build' 'python-installer')
+checkdepends=('flake8' 'python-pytest' 'python-pytest-cov')
+optdepends=()
+source=("$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/$pkgver.tar.gz")
+sha256sums=('c76c2863c6e9a31b8f70ee5b8b0e5ac6860bfd422d930c04a387599e4272b4b9')
+
+build() {
+ python -m build -nw $srcdir/dockerpy-creds-$pkgver
+}
+
+check() {
+ cd $srcdir/dockerpy-creds-$pkgver
+ # NOTE Tests requires `docker` and `docker-credentials`. Testing can clog
+ # your credential store with test credentials. Since a lot of users do not
+ # read PKGBUILDs and builds on their own system, we omit testing.
+ # pytest -v tests
+}
+
+package() {
+ python -m installer \
+ --compile-bytecode=1 \
+ --destdir=$pkgdir \
+ $srcdir/dockerpy-creds-$pkgver/dist/${_pkgname/-/_}-$pkgver-*-*.whl
+}