summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrafcube2023-04-13 15:46:36 +0530
committerGrafcube2023-04-13 15:46:36 +0530
commite3b3139b9baac8ad9c566491edab0ca1cd36d8bb (patch)
tree0938ecf2e4c183ff46ebb0420663e7177f94fb25
downloadaur-e3b3139b9baac8ad9c566491edab0ca1cd36d8bb.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD22
3 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fd8a497c6ac3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-docopt-ng
+ pkgdesc = Jazzband-maintained fork of docopt, the humane command line arguments parser.
+ pkgver = 0.8.1
+ pkgrel = 1
+ url = https://github.com/jazzband/docopt-ng
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ depends = python-regex
+ source = https://files.pythonhosted.org/packages/source/d/docopt-ng/docopt-ng-0.8.1.tar.gz
+ sha256sums = ea6a61a288fc864eee6b22d6fe28aa202d59fc86fad05f16ff5e39cc4ea7f6e3
+
+pkgname = python-docopt-ng
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..2bb3032b76a9
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+*
+
+!.gitignore
+!.SRCINFO
+!PKGBUILD
+!*.patch
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..56335d02367e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+_pkgname=docopt-ng
+pkgname=python-${_pkgname}
+pkgver=0.8.1
+pkgrel=1
+pkgdesc="Jazzband-maintained fork of docopt, the humane command line arguments parser."
+url="https://github.com/jazzband/docopt-ng"
+depends=('python' 'python-regex')
+makedepends=('python-setuptools')
+license=('MIT')
+arch=('any')
+source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/$_pkgname/$_pkgname-$pkgver.tar.gz")
+sha256sums=('ea6a61a288fc864eee6b22d6fe28aa202d59fc86fad05f16ff5e39cc4ea7f6e3')
+
+build() {
+ cd "${_pkgname}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${_pkgname}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}