summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWill Handley2022-06-07 21:36:35 +0100
committerWill Handley2022-06-07 21:36:35 +0100
commit00d236a1f5517967842aa5b38367005a1386aead (patch)
tree5c37dd24c7cc437fbbd4aff65c5728ba55b805d8
parent4aa32ebde71b1bde6bb7a27c85c4ede0e45e64e2 (diff)
downloadaur-00d236a1f5517967842aa5b38367005a1386aead.tar.gz
Updated
-rw-r--r--.SRCINFO7
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD20
3 files changed, 16 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dd4d1ac35c79..035eeef4043a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,14 @@
pkgbase = python-docrep
pkgdesc = A Python Module for intelligent reuse of docstrings
pkgver = 0.3.1
- pkgrel = 1
+ pkgrel = 3
url = https://github.com/Chilipp/docrep
arch = any
license = GPL
makedepends = python-setuptools
makedepends = python-numpy
options = !emptydirs
- source = https://github.com/Chilipp/docrep/archive/v0.3.1.tar.gz
- sha256sums = fd2e92b8fb6b5d79211598e3b7c899a40c1dc408212ceaa26ddb32f487f159b9
+ source = https://files.pythonhosted.org/packages/source/d/docrep/docrep-0.3.1.tar.gz
+ sha256sums = ef6e7433716c0d2c59889aae8bff800b48e82d7e759dfd934b93100dc7bccaa1
pkgname = python-docrep
-
diff --git a/.gitignore b/.gitignore
index b20752a93bec..a6b8c850ccb9 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,5 @@
*.tar.gz
*.tar.xz
+*.tar.zst
pkg/
src/
diff --git a/PKGBUILD b/PKGBUILD
index 77a67c5db990..e182b874c886 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Will Handley <wh260@cam.ac.uk> (aur.archlinux.org/account/wjhandley)
-_modulename=docrep
-pkgname=python-$_modulename
+pkgname=python-docrep
+_name=${pkgname#python-}
pkgver=0.3.1
-pkgrel=1
+pkgrel=3
pkgdesc="A Python Module for intelligent reuse of docstrings"
arch=(any)
url="https://github.com/Chilipp/docrep"
@@ -16,11 +16,15 @@ replaces=()
backup=()
options=(!emptydirs)
install=
-source=("${url}/archive/v${pkgver}.tar.gz")
-sha256sums=('fd2e92b8fb6b5d79211598e3b7c899a40c1dc408212ceaa26ddb32f487f159b9')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
+sha256sums=(ef6e7433716c0d2c59889aae8bff800b48e82d7e759dfd934b93100dc7bccaa1)
+
+build() {
+ cd "$srcdir/$_name-$pkgver"
+ python -m build --wheel --no-isolation
+}
package() {
- cd "$srcdir/$(tar -tf v${pkgver}.tar.gz | head -n1)"
- python setup.py install --root="$pkgdir/" --optimize=1
- mkdir -p "$pkgdir/usr/share/licenses/$pkgname"
+ cd "$srcdir/$_name-$pkgver"
+ python -m installer --destdir="$pkgdir" dist/*.whl
}