summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAseem Athale2024-06-27 13:29:14 +0530
committerAseem Athale2024-06-27 13:29:14 +0530
commit3b08486eb3c7c1d0c4380b39f15a4427c7a9d552 (patch)
treee307564394b0a8e2ad6f05d9b4a6128931efc5bb
downloadaur-3b08486eb3c7c1d0c4380b39f15a4427c7a9d552.tar.gz
python-docx-git: Initial commit
Signed-off-by: Aseem Athale <athaleaseem@gmail.com>
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD33
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b65336e72796
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = python-docx-git
+ pkgdesc = A Python library for creating and updating Microsoft Word (.docx) files
+ pkgver = 1.1.2.r0.g0cf6d71
+ pkgrel = 1
+ url = https://github.com/python-openxml/python-docx
+ arch = any
+ license = MIT
+ makedepends = git
+ makedepends = python-setuptools
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
+ depends = python
+ depends = python-lxml
+ depends = python-typing_extensions
+ provides = python-docx
+ conflicts = python-docx
+ source = git+https://github.com/python-openxml/python-docx.git
+ sha512sums = SKIP
+
+pkgname = python-docx-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..24d3d947f1ef
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Aseem Athale <athaleaseem@gmail.com>
+
+_pkg=python-docx
+pkgname=${_pkg}-git
+pkgver=1.1.2.r0.g0cf6d71
+pkgrel=1
+pkgdesc="A Python library for creating and updating Microsoft Word (.docx) files"
+arch=('any')
+url="https://github.com/python-openxml/python-docx"
+license=('MIT')
+depends=('python' 'python-lxml' 'python-typing_extensions')
+makedepends=('git' 'python-setuptools' 'python-build' 'python-installer' 'python-wheel')
+provides=('python-docx')
+conflicts=('python-docx')
+source=("git+${url}.git")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "${_pkg}"
+ git describe --long --tags --abbrev=7 | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${_pkg}"
+ python -m build --wheel --no-isolation
+}
+
+
+package() {
+ cd "${_pkg}"
+ python -m installer --destdir="$pkgdir" dist/*.whl
+ install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
+}