summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonas DOREL2021-03-21 12:27:17 +0100
committerJonas DOREL2021-03-21 12:27:17 +0100
commitd0ad7784f3693c65289ca017b760ae901433d764 (patch)
treecc6a88500181f086f766658052cdf292e0f709dd
parent85a768e1d0f41f94b9a91ccee48f41c08b498494 (diff)
downloadaur-d0ad7784f3693c65289ca017b760ae901433d764.tar.gz
Update PKDBUILD
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD34
2 files changed, 21 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d5d385b1191f..3cc971103946 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = python-dodgy
- pkgdesc = Looks at Python code to search for things which look dodgy such as passwords or diffs
+ pkgdesc = Searches for dodgy looking lines in Python code
pkgver = 0.2.1
pkgrel = 1
url = https://github.com/landscapeio/dodgy
arch = any
license = MIT
makedepends = python-setuptools
- makedepends = git
depends = python
- source = git+https://github.com/landscapeio/dodgy#tag=0.2.1
- sha256sums = SKIP
+ source = https://files.pythonhosted.org/packages/source/d/dodgy/dodgy-0.2.1.tar.gz
+ sha256sums = 28323cbfc9352139fdd3d316fa17f325cc0e9ac74438cbba51d70f9b48f86c3a
pkgname = python-dodgy
+ depends = python
diff --git a/PKGBUILD b/PKGBUILD
index 4d5b85c8e531..39011333777d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,27 @@
-# Maintainer: Sven-Hendrik Haase <sh@lutzhaase.com>
-# Maintainer: Nathan Owens <ndowens @ artixlinux.org>
+# Maintainer: Jonas DOREL <jonas at dorel dot me>
-pkgname=python-dodgy
-pkgver=0.2.1
+pkgbase='python-dodgy'
+pkgname=('python-dodgy')
+_module='dodgy'
+pkgver='0.2.1'
pkgrel=1
-pkgdesc="Looks at Python code to search for things which look dodgy such as passwords or diffs"
-arch=('any')
+pkgdesc="Searches for dodgy looking lines in Python code"
url="https://github.com/landscapeio/dodgy"
-license=('MIT')
depends=('python')
-makedepends=('python-setuptools' 'git')
-source=(git+https://github.com/landscapeio/dodgy#tag=${pkgver})
-sha256sums=('SKIP')
+makedepends=('python-setuptools')
+license=('MIT')
+arch=('any')
+source=("https://files.pythonhosted.org/packages/source/${_module::1}/$_module/$_module-$pkgver.tar.gz")
+sha256sums=('28323cbfc9352139fdd3d316fa17f325cc0e9ac74438cbba51d70f9b48f86c3a')
build() {
- cd "dodgy"
-
- python setup.py build
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py build
}
package() {
- cd "dodgy"
-
- python setup.py install --prefix="/usr" --root="${pkgdir}" --optimize=1
- install -Dm755 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}"/LICENSE
+ depends+=()
+ cd "${srcdir}/${_module}-${pkgver}"
+ PIP_CONFIG_FILE=/dev/null
+ python setup.py install --isolated --root="${pkgdir}" --ignore-installed --no-deps --optimize=1 --skip-build
}