summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Warrick2014-12-31 11:00:34 +0100
committerChris Warrick2014-12-31 11:00:34 +0100
commit38eb266908f0e89c776eb10bc8bf07d157874f1d (patch)
tree59f3ee8f338dc99103eafca6c1449465236bd641
downloadaur-38eb266908f0e89c776eb10bc8bf07d157874f1d.tar.gz
init python-doit
Signed-off-by: Chris Warrick <kwpolska@gmail.com>
-rw-r--r--.SRCINFO18
-rw-r--r--LICENSE23
-rw-r--r--PKGBUILD23
3 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5d6e6a8ba5ed
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python-doit
+ pkgdesc = Automation Tool
+ pkgver = 0.26.0
+ pkgrel = 1
+ url = http://pydoit.org/
+ arch = any
+ license = MIT
+ depends = python
+ depends = python-pyinotify
+ depends = python-six
+ options = !emptydirs
+ source = http://pypi.python.org/packages/source/d/doit/doit-0.26.0.tar.gz
+ source = LICENSE
+ md5sums = 24d83f64024649e701f4dd2f0e391980
+ md5sums = 7d6fd7c8e022bae9010af272c31eb45f
+
+pkgname = python-doit
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..9340ee9a6b68
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,23 @@
+
+
+The MIT License
+
+Copyright (c) 2008-2011 Eduardo Naufel Schettino
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in
+all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
+THE SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f13cf5f9f1fc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Chris Warrick <aur@chriswarrick.com>
+pkgname=python-doit
+_pyname=doit
+pkgver=0.26.0
+pkgrel=1
+pkgdesc='Automation Tool'
+arch=('any')
+url='http://pydoit.org/'
+license=('MIT')
+depends=('python' 'python-pyinotify' 'python-six')
+options=(!emptydirs)
+source=("http://pypi.python.org/packages/source/$(echo ${_pyname} | cut -c1)/${_pyname}/${_pyname}-${pkgver}.tar.gz"
+ "LICENSE")
+md5sums=('24d83f64024649e701f4dd2f0e391980'
+ '7d6fd7c8e022bae9010af272c31eb45f')
+
+package() {
+ cd "${srcdir}/${_pyname}-${pkgver}"
+ python3 setup.py install --root="${pkgdir}/" --optimize=1
+ install -D -m644 ../LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et: