summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Warrick2014-12-31 11:11:05 +0100
committerChris Warrick2014-12-31 11:11:05 +0100
commit421a3025d6274f2a0d32a49fc4e3f9880e50eb0e (patch)
tree8c99080d82e9f7d1218c651419e8459dde02f631
downloadaur-421a3025d6274f2a0d32a49fc4e3f9880e50eb0e.tar.gz
init python-doit-git
Signed-off-by: Chris Warrick <kwpolska@gmail.com>
-rw-r--r--.SRCINFO19
-rw-r--r--LICENSE23
-rw-r--r--PKGBUILD29
3 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d978bc156a2a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = python-doit-git
+ pkgdesc = Automation Tool (git version)
+ pkgver = 0.26.0.r22.g6a945db
+ pkgrel = 1
+ url = http://pydoit.org/
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = python
+ depends = python-pyinotify
+ depends = python-six
+ options = !emptydirs
+ source = git://github.com/pydoit/doit.git
+ source = LICENSE
+ md5sums = SKIP
+ md5sums = 7d6fd7c8e022bae9010af272c31eb45f
+
+pkgname = python-doit-git
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..9340ee9a6b68
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,23 @@
+
+
+The MIT License
+
+Copyright (c) 2008-2011 Eduardo Naufel Schettino
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in
+all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
+THE SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..05a0bad4ad64
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Chris Warrick <aur@chriswarrick.com>
+pkgname=python-doit-git
+_pyname=doit
+_gitname=doit
+pkgver=0.26.0.r22.g6a945db
+pkgrel=1
+pkgdesc='Automation Tool (git version)'
+arch=('any')
+url='http://pydoit.org/'
+license=('MIT')
+depends=('python' 'python-pyinotify' 'python-six')
+makedepends=('git')
+options=(!emptydirs)
+source=("git://github.com/pydoit/${_gitname}.git"
+ "LICENSE")
+md5sums=('SKIP' '7d6fd7c8e022bae9010af272c31eb45f')
+
+package() {
+ cd "${srcdir}/${_gitname}"
+ python setup.py install --root="${pkgdir}/" --optimize=1
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+pkgver() {
+ cd "${srcdir}/${_gitname}"
+ git describe --long --tags | sed -E 's/([^-]*-g)/r\1/;s/-/./g'
+}
+
+# vim:set ts=2 sw=2 et: