summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsigvaldm2018-06-23 11:11:46 +0200
committersigvaldm2018-06-23 11:11:46 +0200
commita539e509a33880371a7dc833981bd9b7438d094d (patch)
treebe96f965ad8577b5d9c450404ff63722af8f1a16
downloadaur-a539e509a33880371a7dc833981bd9b7438d094d.tar.gz
Initial commit
-rw-r--r--.SRCINFO23
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD40
3 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b49774c63ead
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = python-dolfin
+ pkgdesc = The Python interface of FEniCS, providing a consistent PSE (Problem Solving Environment) for ordinary and partial differential equations (stable).
+ pkgver = 2018.1.0
+ pkgrel = 1
+ url = https://bitbucket.org/fenics-project/dolfin
+ arch = i686
+ arch = x86_64
+ groups = fenics
+ license = LGPL3
+ depends = dolfin=2018.1.0
+ depends = python-pkgconfig
+ depends = python-ply
+ optdepends = python-mpi4py: MPI library for python
+ optdepends = petsc4py: interface with PETSc from python
+ optdepends = slepc4py: interface with SLEPc from python
+ optdepends = python-matplotlib: plotting support
+ conflicts = python-dolfin-git
+ options = !emptydirs
+ source = python-dolfin-2018.1.0.tar.gz::https://bitbucket.org/fenics-project/dolfin/downloads/dolfin-2018.1.0.tar.gz
+ sha256sums = 5d1836df4dcc1d55f63ecc20635305a6d5b39cbfc63584b43ec2568452dc5e71
+
+pkgname = python-dolfin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..3f1864bb0ec4
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg
+src
+*.tar.gz
+*.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fa2cece8e3aa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Sigvald Marholm <marholm@marebakken.com>
+# Based on dolfin-git, maintained by Lucas H. Gabrielli <heitzmann@gmail.com> and submitted by myles
+
+_base=dolfin
+pkgname=python-${_base}
+pkgdesc="The Python interface of FEniCS, providing a consistent PSE (Problem Solving Environment) for ordinary and partial differential equations (stable)."
+pkgver=2018.1.0
+pkgrel=1
+arch=('i686' 'x86_64')
+url="https://bitbucket.org/fenics-project/${_base}"
+license=('LGPL3')
+groups=('fenics')
+conflicts=('python-dolfin-git')
+depends=('dolfin=2018.1.0'
+ 'python-pkgconfig'
+ 'python-ply')
+optdepends=('python-mpi4py: MPI library for python'
+ 'petsc4py: interface with PETSc from python'
+ 'slepc4py: interface with SLEPc from python'
+ 'python-matplotlib: plotting support')
+options=(!emptydirs)
+source=(${pkgname}-${pkgver}.tar.gz::https://bitbucket.org/fenics-project/${_base}/downloads/${_base}-${pkgver}.tar.gz)
+sha256sums=('5d1836df4dcc1d55f63ecc20635305a6d5b39cbfc63584b43ec2568452dc5e71')
+
+export MAKEFLAGS="-j1"
+
+build() {
+ [ -n "$PETSC_DIR" ] && source /etc/profile.d/petsc.sh
+ [ -n "$SLEPC_DIR" ] && source /etc/profile.d/slepc.sh
+
+ cd ${srcdir}/${_base}-${pkgver}/python
+ python setup.py build
+}
+
+package() {
+ cd ${srcdir}/${_base}-${pkgver}/python
+ python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1
+}
+
+# vim: shiftwidth=2 softtabstop=2 tabstop=2 noexpandtab