summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfunilrys2018-10-14 00:14:22 +0200
committerfunilrys2018-10-14 00:14:22 +0200
commit350a4f035a77f5c74b087d4acacda6246b08c4e1 (patch)
treef77a7f057151617495831b271a449347dc4cdd2b
downloadaur-350a4f035a77f5c74b087d4acacda6246b08c4e1.tar.gz
Introduction of python-domain2idna
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD35
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dcb836eccc2b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python-domain2idna
+ pkgdesc = The tool to convert domains the famous IDNA format.
+ pkgver = 1.6.1
+ pkgrel = 1
+ url = https://github.com/funilrys/domain2idna
+ arch = any
+ license = MIT
+ depends = python3
+ depends = python-distribute
+ depends = python-setuptools
+ depends = python-colorama
+ source = https://files.pythonhosted.org/packages/source/d/domain2idna/domain2idna-1.6.1.tar.gz
+ source = https://raw.githubusercontent.com/funilrys/domain2idna/master/LICENSE
+ sha256sums = e55f6f934eb6dab00cae7849226f7190e4f5c63a8872460507c6014d088e61ac
+ sha256sums = 3e51a4436b9d46fe6b44ceaff1dcf36e392acb7128130ee8a6a80748a4b087a5
+
+pkgname = python-domain2idna
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3bd18185e935
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Nissar Chababy <contact at funilrys dot com>
+
+pkgname=python-domain2idna
+_name=${pkgname#python-}
+pkgver=1.6.1
+pkgrel=1
+pkgdesc="The tool to convert domains the famous IDNA format."
+arch=('any')
+url="https://github.com/funilrys/domain2idna"
+license=('MIT')
+depends=(
+ 'python3'
+ 'python-distribute'
+ 'python-setuptools'
+ 'python-colorama'
+)
+source=(
+ "https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz"
+ "https://raw.githubusercontent.com/funilrys/domain2idna/master/LICENSE"
+)
+sha256sums=(
+ "e55f6f934eb6dab00cae7849226f7190e4f5c63a8872460507c6014d088e61ac"
+ "3e51a4436b9d46fe6b44ceaff1dcf36e392acb7128130ee8a6a80748a4b087a5"
+)
+
+build() {
+ cd ${srcdir}/${_name}-${pkgver}
+ python setup.py build
+}
+
+package() {
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ cd ${srcdir}/${_name}-${pkgver}
+ python setup.py install --root="${pkgdir}/" --optimize=1 --skip-build
+}