summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxime “pep” Buquet2018-09-08 22:16:59 +0100
committerMaxime “pep” Buquet2018-09-08 22:16:59 +0100
commitaaf0d3ba31bc4592c83ec117d7a2630fef3d7da1 (patch)
tree401be068ec14ba24004ad7a7c6d48db2c24a5b11
parent058ae7fb8a4ddeb685331e2303eac0df89d4ee66 (diff)
downloadaur-aaf0d3ba31bc4592c83ec117d7a2630fef3d7da1.tar.gz
Add python2 support
Signed-off-by: Maxime “pep” Buquet <pep@bouah.net>
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD34
2 files changed, 37 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 857dd5c3d496..ca8d976e9486 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,26 @@
pkgbase = python-doubleratchet-git
pkgdesc = A python implementation of the Double Ratchet algorithm
- pkgver = r21.abfedd0
- pkgrel = 1
+ pkgver = r27.9ccb6c6
+ pkgrel = 2
url = https://github.com/Syndace/python-doubleratchet
arch = any
license = MIT
makedepends = python-setuptools
+ makedepends = python2-setuptools
+ source = python-doubleratchet::git+https://github.com/Syndace/python-doubleratchet.git
+ sha256sums = SKIP
+
+pkgname = python-doubleratchet-git
depends = python-pynacl
depends = python-cryptography
depends = python-hkdf
- depends = python-scci-git
provides = python-doubleratchet
conflicts = python-doubleratchet
- source = python-doubleratchet::git+https://github.com/Syndace/python-doubleratchet.git
- sha256sums = SKIP
-pkgname = python-doubleratchet-git
+pkgname = python2-doubleratchet-git
+ depends = python2-pynacl
+ depends = python2-cryptography
+ depends = python2-hkdf
+ provides = python2-doubleratchet
+ conflicts = python2-doubleratchet
diff --git a/PKGBUILD b/PKGBUILD
index e337c697ae91..7dfda64c27c2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,16 @@
# Maintainer: Maxime "pep" Buquet <archlinux@bouah.net>
_pkgname=python-doubleratchet
-pkgname=${_pkgname}-git
-pkgver=r21.abfedd0
-pkgrel=1
+_pkgname2=python2-doubleratchet
+pkgbase=${_pkgname}-git
+pkgname=("${_pkgname}-git" "${_pkgname2}-git")
+pkgver=r27.9ccb6c6
+pkgrel=2
pkgdesc="A python implementation of the Double Ratchet algorithm"
url='https://github.com/Syndace/python-doubleratchet'
license=('MIT')
arch=('any')
-depends=('python-pynacl'
- 'python-cryptography'
- 'python-hkdf')
-makedepends=('python-setuptools')
-provides=("${_pkgname}")
-conflicts=("${_pkgname}")
+makedepends=('python-setuptools' 'python2-setuptools')
source=("${_pkgname}::git+https://github.com/Syndace/${_pkgname}.git")
sha256sums=('SKIP')
@@ -22,7 +19,24 @@ pkgver() {
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-package() {
+package_python-doubleratchet-git() {
+ depends=('python-pynacl'
+ 'python-cryptography'
+ 'python-hkdf')
+ provides=("${_pkgname}")
+ conflicts=("${_pkgname}")
+
cd ${_pkgname}
python3 setup.py install --root="${pkgdir}" --optimize=1
}
+
+package_python2-doubleratchet-git() {
+ depends=('python2-pynacl'
+ 'python2-cryptography'
+ 'python2-hkdf')
+ provides=("${_pkgname2}")
+ conflicts=("${_pkgname2}")
+
+ cd ${_pkgname}
+ python2 setup.py install --root="${pkgdir}" --optimize=1
+}