summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSkycoder422018-01-31 16:46:11 +0100
committerSkycoder422018-01-31 16:46:11 +0100
commit62e51fc16184d6f7a3701a9bbd389b3578523704 (patch)
tree3ff77a0340e2a8280d5653bbab95331bba871713
downloadaur-62e51fc16184d6f7a3701a9bbd389b3578523704.tar.gz
Initial release
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD18
3 files changed, 33 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ff8e5e6c1c1b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-doxyqml
+ pkgdesc = Doxyqml turns .qml into pseudo-C++ which Doxygen can then use to generate documentation.
+ pkgver = 0.3.0
+ pkgrel = 1
+ url = https://github.com/agateau/doxyqml
+ arch = any
+ license = BSD
+ depends = python
+ depends = doxygen
+ source = python-doxyqml-0.3.0::git+https://github.com/agateau/doxyqml.git#tag=0.3.0
+ sha256sums = SKIP
+
+pkgname = python-doxyqml
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..72e8ffc0db8a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3cfcf8ee60f4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Felix Barz <skycoder42.de@gmx.de>
+pkgname=python-doxyqml
+pkgver=0.3.0
+pkgrel=1
+pkgdesc="Doxyqml turns .qml into pseudo-C++ which Doxygen can then use to generate documentation."
+arch=('any')
+url="https://github.com/agateau/doxyqml"
+license=('BSD')
+depends=('python' 'doxygen')
+_pkgfqn=$pkgname-$pkgver
+source=("$_pkgfqn::git+https://github.com/agateau/doxyqml.git#tag=$pkgver")
+sha256sums=('SKIP')
+
+package() {
+ cd "$srcdir/$_pkgfqn"
+ python setup.py install --root="$pkgdir/" --optimize=1
+ install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}