summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaikel Wever2017-08-02 12:38:21 +0200
committerMaikel Wever2017-08-02 12:38:21 +0200
commit1bd2101e067fa7fa0c233009d06121573e6f7447 (patch)
treecaba115ffb0a76303021ecc203cc58dd224fd50c
downloadaur-1bd2101e067fa7fa0c233009d06121573e6f7447.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD21
3 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d45fe6170909
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Wed Aug 2 10:38:17 UTC 2017
+pkgbase = python-dparse
+ pkgdesc = A parser for Python dependency files
+ pkgver = 0.2.1
+ pkgrel = 1
+ url = https://github.com/pyupio/dparse
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ depends = python-packaging
+ depends = python-six
+ depends = python-yaml
+ source = https://github.com/pyupio/dparse/archive/0.2.1.tar.gz
+ md5sums = 695cecf2fac46046e2cf7dc204db134a
+
+pkgname = python-dparse
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e28f6f20ed95
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+src
+pkg
+*.sign
+*.xz
+*.pkg*
+*.part
+*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9aad58989e7c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Maikel Wever <maikelwever@gmail.com>
+pkgname=python-dparse
+pkgver=0.2.1
+pkgrel=1
+pkgdesc="A parser for Python dependency files"
+url="https://github.com/pyupio/dparse"
+license=('MIT')
+depends=('python' 'python-packaging' 'python-six' 'python-yaml')
+makedepends=('python-setuptools')
+source=("https://github.com/pyupio/dparse/archive/${pkgver}.tar.gz")
+md5sums=('695cecf2fac46046e2cf7dc204db134a')
+arch=('any')
+
+package() {
+ cd "$srcdir/dparse-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+ mkdir -p ${pkgdir}/usr/share/licenses/${pkgname}
+ cp LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.txt
+}
+
+# vim:set ts=2 sw=2 et: