summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAmos Onn2018-11-22 02:19:00 +0100
committerAmos Onn2018-11-22 02:32:45 +0100
commitee3dd51473d4f399745fe515703e9915366786bb (patch)
treee997f97923bba13924f5fc912000e366aff2712a
parent29ae18eabd7258d66a49f79ec58f822d516e6759 (diff)
downloadaur-ee3dd51473d4f399745fe515703e9915366786bb.tar.gz
Bumped to r5, with python3 support.
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD24
2 files changed, 21 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 98538ead497a..3848259cfab3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,21 @@
# Generated by mksrcinfo v8
-# Thu Nov 22 01:18:09 UTC 2018
+# Thu Nov 22 01:31:53 UTC 2018
pkgbase = python-dpms
pkgdesc = Python Bindings to DPMS X11 extension
- pkgver = r4.688e645
+ pkgver = r5.e41b902
pkgrel = 1
url = https://github.com/dirjud/python-dpms
arch = any
license = UNKNOWN
depends = libx11
depends = libxext
- source = https://codeload.github.com/dirjud/python-dpms/tar.gz/688e645
- sha256sums = caee5726af9bf35165b298091f3defc088c92f3fbbd206659de2d166126afece
+ source = https://codeload.github.com/amosonn/python-dpms/tar.gz/e41b902
+ sha256sums = 4b48b367f5fac65e242031399cbb65c3dab70a8f31dc7eaac9aae018f04c93b6
+
+pkgname = python-dpms
+ depends = libx11
+ depends = libxext
+ depends = python
pkgname = python2-dpms
depends = libx11
diff --git a/PKGBUILD b/PKGBUILD
index 98d71a629ff3..7f1febcd6866 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,29 @@
# Maintainer: Amos Onn <amosonn at gmail dot com>
pkgbase=python-dpms
-pkgname=('python2-dpms')
+pkgname=('python-dpms' 'python2-dpms')
_pkgname=python-dpms
-_pkgver=688e645
-pkgver=r4.$_pkgver
+_pkgver=e41b902
+pkgver=r5.$_pkgver
pkgrel=1
pkgdesc="Python Bindings to DPMS X11 extension"
arch=('any')
url="https://github.com/dirjud/python-dpms"
license=("UNKNOWN")
depends=('libx11' 'libxext')
-source=(https://codeload.github.com/dirjud/python-dpms/tar.gz/$_pkgver)
-sha256sums=('caee5726af9bf35165b298091f3defc088c92f3fbbd206659de2d166126afece')
+source=(https://codeload.github.com/amosonn/python-dpms/tar.gz/$_pkgver)
+sha256sums=('4b48b367f5fac65e242031399cbb65c3dab70a8f31dc7eaac9aae018f04c93b6')
prepare() {
cp -a $_pkgname-$_pkgver{,-py2}
}
-#package_python-dpms() {
- #depends+=('python')
- #cd $srcdir/$_pkgname-$_pkgver
- #python setup.py install --root=$pkgdir || return 1
- ##install -d $pkgdir/usr/share/licenses/$pkgname
- ##install LICENSE.txt $pkgdir/usr/share/licenses/$pkgname/COPYING
-#}
+package_python-dpms() {
+ depends+=('python')
+ cd $srcdir/$_pkgname-$_pkgver
+ python setup.py install --root=$pkgdir || return 1
+ #install -d $pkgdir/usr/share/licenses/$pkgname
+ #install LICENSE.txt $pkgdir/usr/share/licenses/$pkgname/COPYING
+}
package_python2-dpms() {
depends+=('python2')