summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSilvio Ankermann2020-05-23 12:10:33 +0200
committerSilvio Ankermann2020-05-23 12:10:33 +0200
commit716b5f83101c1fe14cf06c101c4b9ec6e3aaea79 (patch)
tree1b9b21f213b66f365714636b69db0b75cb44730a
downloadaur-716b5f83101c1fe14cf06c101c4b9ec6e3aaea79.tar.gz
v0.1.4
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD20
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1519d4414c23
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = python-drivelib
+ pkgdesc = Easy access to the most common Google Drive API calls
+ pkgver = 0.1.4
+ pkgrel = 1
+ url = https://github.com/Lykos153/python-drivelib
+ arch = any
+ license = GPLv3+
+ makedepends = python-setuptools
+ depends = python
+ depends = python-google-api-python-client
+ depends = python-google-auth-oauthlib
+ depends = python-google-auth-httplib2
+ depends = python-google-auth
+ depends = python-oauth2client
+ source = git+https://github.com/Lykos153/python-drivelib.git#tag=v0.1.4
+ sha256sums = SKIP
+
+pkgname = python-drivelib
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c819753093e1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Silvio Ankermann < silvio at booq dot org >
+
+pkgname=python-drivelib
+pkgver=0.1.4
+pkgrel=1
+pkgdesc='Easy access to the most common Google Drive API calls'
+url='https://github.com/Lykos153/python-drivelib'
+license=('GPLv3+')
+arch=('any')
+depends=('python' 'python-google-api-python-client' 'python-google-auth-oauthlib' 'python-google-auth-httplib2' 'python-google-auth' 'python-oauth2client')
+makedepends=('python-setuptools')
+source=("git+https://github.com/Lykos153/${pkgname}.git#tag=v${pkgver}")
+sha256sums=('SKIP')
+
+
+package() {
+ cd "${srcdir}/${pkgname}"
+
+ python setup.py install --optimize=1 "--root=${pkgdir}"
+}