summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2019-08-30 15:37:28 +0800
committerUniversebenzene2019-08-30 15:37:28 +0800
commit49175e2fd49e969f47c3dfa128fe9a662a3599b2 (patch)
tree2565692b633e44f077b44279c76506105835d977
parent2e18c1ca00fc21c3193b87496e21f73374cae2a8 (diff)
downloadaur-49175e2fd49e969f47c3dfa128fe9a662a3599b2.tar.gz
Fix file conflicts
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD5
2 files changed, 5 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 316e49b04ec0..0e66d2c2a76c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-drizzlepac
pkgdesc = AstroDrizzle for HST images
pkgver = 2.2.6
- pkgrel = 1
+ pkgrel = 2
url = http://www.stsci.edu/scientific-community/software/drizzlepac.html
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 34a3aec079c4..be2e8c2ca7f3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@ pkgbase=python-drizzlepac
_pyname=${pkgbase#python-}
pkgname=("python-${_pyname}" "python-${_pyname}-doc")
pkgver=2.2.6
-pkgrel=1
+pkgrel=2
pkgdesc="AstroDrizzle for HST images"
arch=('i686' 'x86_64')
url="http://www.stsci.edu/scientific-community/software/drizzlepac.html"
@@ -31,6 +31,7 @@ source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname
"https://raw.githubusercontent.com/spacetelescope/drizzlepac/master/LICENSE.txt")
md5sums=('a4212f8f8d4c8aaaa69d4f20d6053fae'
'b45bee901c15ab7e1ac3e5e3626d535d')
+_pyver=$(python -V | cut -c 8-10)
prepare() {
cd ${srcdir}/${_pyname}-${pkgver}
@@ -75,6 +76,8 @@ package_python-drizzlepac() {
install -D -m644 -t "${pkgdir}/usr/share/licenses/${pkgname}" LICENSE.txt
install -D -m644 -t "${pkgdir}/usr/share/doc/${pkgname}" README.md
python setup.py install --root=${pkgdir} --prefix=/usr --optimize=1
+ rm "${pkgdir}/usr/lib/python${_pyver}/site-packages/tests/__init__.py"
+ rm "${pkgdir}/usr/lib/python${_pyver}/site-packages/tests/__pycache__"/__init__*
}
package_python-drizzlepac-doc() {