summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2020-07-04 15:08:27 +0800
committerUniversebenzene2020-07-04 15:08:27 +0800
commit8778a70119939fe4b8a91a0667ae7eccb35dcc3b (patch)
tree7947033ac2444f0fd58186bc008808fb67dde8d5
parent19a67002a9a69fba6a49aa5c1e02e6fb15dbc6a5 (diff)
downloadaur-8778a70119939fe4b8a91a0667ae7eccb35dcc3b.tar.gz
Update to version 3.1.6
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD16
2 files changed, 15 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bdd18f7f930e..7e5b901a2d2a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-drizzlepac
pkgdesc = AstroDrizzle for HST images
- pkgver = 3.1.3
+ pkgver = 3.1.6
pkgrel = 1
url = http://www.stsci.edu/scientific-community/software/drizzlepac.html
arch = i686
@@ -9,10 +9,10 @@ pkgbase = python-drizzlepac
makedepends = python-setuptools
makedepends = python-relic
makedepends = python-astropy
- source = https://files.pythonhosted.org/packages/source/d/drizzlepac/drizzlepac-3.1.3.tar.gz
+ source = https://files.pythonhosted.org/packages/source/d/drizzlepac/drizzlepac-3.1.6.tar.gz
source = https://raw.githubusercontent.com/spacetelescope/drizzlepac/master/LICENSE.txt
- md5sums = 2a7a7f54680cad6c3947af4c5911a991
- md5sums = b45bee901c15ab7e1ac3e5e3626d535d
+ md5sums = f3649c579580ed444bf865cffcf53c83
+ md5sums = SKIP
pkgname = python-drizzlepac
depends = python>=3.5
diff --git a/PKGBUILD b/PKGBUILD
index 4687367cd9a9..7e4e0459c2be 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@ pkgbase=python-drizzlepac
_pyname=${pkgbase#python-}
pkgname=("python-${_pyname}")
#"python-${_pyname}-doc")
-pkgver=3.1.3
+pkgver=3.1.6
pkgrel=1
pkgdesc="AstroDrizzle for HST images"
arch=('i686' 'x86_64')
@@ -28,16 +28,22 @@ makedepends=('python-setuptools'
# 'python-fitsblender'
# 'python-nictools')
#checkdepends=('python-pytest-remotedata' 'python-nose' 'python-ci_watson' 'python-crds')
+#checkdepends=('python-pytest'
+# 'python-stsci.tools'
+# 'python-stwcs'
+# 'python-stsci.skypac'
+# 'python-fitsblender'
+# 'python-ci_watson')
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz"
"https://raw.githubusercontent.com/spacetelescope/drizzlepac/master/LICENSE.txt")
-md5sums=('2a7a7f54680cad6c3947af4c5911a991'
- 'b45bee901c15ab7e1ac3e5e3626d535d')
-_pyver=$(python -V | cut -c 8-10)
+md5sums=('f3649c579580ed444bf865cffcf53c83'
+ 'SKIP')
prepare() {
cd ${srcdir}/${_pyname}-${pkgver}
ln -rs ${srcdir}/LICENSE.txt .
+ export _pyver=$(python -c 'import sys; print("%d.%d" % sys.version_info[:2])')
}
build() {
@@ -51,7 +57,7 @@ build() {
#check() {
# cd ${srcdir}/${_pyname}-${pkgver}
#
-# python setup.py test
+# pytest
#}
package_python-drizzlepac() {