summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2020-12-18 17:52:58 +0800
committerUniversebenzene2020-12-18 17:52:58 +0800
commita4c363d99c7d00378751401d495ad55cfc98528b (patch)
tree5dced79e48871a456edda6ef12292bc1ab304024
parent760a86089c084741405d3eaa34e0475148b8392a (diff)
downloadaur-a4c363d99c7d00378751401d495ad55cfc98528b.tar.gz
Update to version 3.2.0
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD25
-rw-r--r--fix_changelog_title.patch11
3 files changed, 42 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c190509b8ece..361c215b8688 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,28 @@
pkgbase = python-drizzlepac-doc
pkgdesc = Documentation for DrizzlePac
- pkgver = 3.1.8
+ pkgver = 3.2.0
pkgrel = 1
url = http://www.stsci.edu/scientific-community/software/drizzlepac.html
arch = i686
arch = x86_64
license = BSD
- makedepends = python-drizzlepac=3.1.8
+ makedepends = python-drizzlepac=3.2.0
makedepends = graphviz
makedepends = python-numpydoc
makedepends = python-sphinx_rtd_theme
+ makedepends = python-astroquery
+ makedepends = python-photutils
+ makedepends = python-pandas
makedepends = python-stsci_rtd_theme
makedepends = python-sphinx-automodapi
makedepends = python-ci_watson
makedepends = texlive-latexextra
- source = https://github.com/spacetelescope/drizzlepac/archive/3.1.8.tar.gz
- md5sums = ed54c8f0e3d2bb3bf16a5dbd83369951
+ makedepends = python-bokeh
+ makedepends = python-pypdf2
+ source = https://github.com/spacetelescope/drizzlepac/archive/3.2.0.tar.gz
+ source = fix_changelog_title.patch
+ md5sums = 645c348dad8e3ff49e62cbf2fd226a0e
+ md5sums = 248fa756065bb5cf939c1180cb58d1e7
pkgname = python-drizzlepac-doc
diff --git a/PKGBUILD b/PKGBUILD
index 2ef87db38b38..c248820781dc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,39 @@
# Maintainer: Astro Benzene <universebenzene at sina dot com>
_pyname=drizzlepac
pkgname=python-${_pyname}-doc
-pkgver=3.1.8
+pkgver=3.2.0
pkgrel=1
pkgdesc="Documentation for DrizzlePac"
arch=('i686' 'x86_64')
url="http://www.stsci.edu/scientific-community/software/drizzlepac.html"
license=('BSD')
-makedepends=("python-${_pyname}=${pkgver}" 'graphviz' 'python-numpydoc' 'python-sphinx_rtd_theme' 'python-stsci_rtd_theme' 'python-sphinx-automodapi' 'python-ci_watson' 'texlive-latexextra')
-source=("https://github.com/spacetelescope/${_pyname}/archive/${pkgver}.tar.gz")
+makedepends=("python-${_pyname}=${pkgver}"
+ 'graphviz'
+ 'python-numpydoc'
+ 'python-sphinx_rtd_theme'
+ 'python-astroquery'
+ 'python-photutils'
+ 'python-pandas'
+ 'python-stsci_rtd_theme'
+ 'python-sphinx-automodapi'
+ 'python-ci_watson'
+ 'texlive-latexextra'
+ 'python-bokeh'
+ 'python-pypdf2')
+source=("https://github.com/spacetelescope/${_pyname}/archive/${pkgver}.tar.gz"
+ 'fix_changelog_title.patch')
#source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz"
# "https://raw.githubusercontent.com/spacetelescope/drizzlepac/master/LICENSE.txt"
# "https://raw.githubusercontent.com/spacetelescope/drizzlepac/master/CHANGELOG.rst")
-md5sums=('ed54c8f0e3d2bb3bf16a5dbd83369951')
+md5sums=('645c348dad8e3ff49e62cbf2fd226a0e'
+ '248fa756065bb5cf939c1180cb58d1e7')
prepare() {
cd ${srcdir}/${_pyname}-${pkgver}
mv ${_pyname} _${_pyname}
-# ln -rs ${srcdir}/{LICENSE.txt,CHANGELOG.rst} .
+ patch -Np1 -i "${srcdir}/fix_changelog_title.patch"
+# ln -rs ${srcdir}/{LICENSE.txt,ANGELOG.rst} .
}
build() {
diff --git a/fix_changelog_title.patch b/fix_changelog_title.patch
new file mode 100644
index 000000000000..a88f883dafee
--- /dev/null
+++ b/fix_changelog_title.patch
@@ -0,0 +1,11 @@
+--- a/CHANGELOG.rst 2020-12-08 07:16:12.000000000 +0800
++++ b/CHANGELOG.rst 2020-12-18 17:33:00.372643789 +0800
+@@ -31,7 +31,7 @@
+
+
+ 3.1.8 (11-Aug-2020)
+-==================
++===================
+
+ A number of changes have been implemented to either correct problems or
+ improve the processed results. The most significant of the changes are: