summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Bocken2024-04-16 08:54:26 +0200
committerAlexander Bocken2024-04-16 08:54:26 +0200
commit9f6c4ff89306b1f1ab3693ebe552a26c0f0e6ee1 (patch)
tree4e8807540ea7a31eeae18d67cb0eae20c9a1d2e5
downloadaur-9f6c4ff89306b1f1ab3693ebe552a26c0f0e6ee1.tar.gz
initial commit
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD27
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3c0cfb8c0749
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = python-dscribe
+ pkgdesc = Creating feature transformations in applications of ML to materials science
+ pkgver = 2.1.0
+ pkgrel = 1
+ url = https://singroup.github.io/dscribe/
+ arch = any
+ license = Apache-2.0
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
+ makedepends = meson-python
+ depends = python>3.7
+ depends = pybind11>=2.4
+ depends = python-numpy
+ depends = python-scipy
+ depends = python-ase>=3.19.0
+ depends = python-scikit-learn
+ depends = python-joblib>=1.0.0
+ depends = python-sparse
+ source = https://files.pythonhosted.org/packages/source/d/dscribe/dscribe-2.1.0.tar.gz
+ sha256sums = cbeb6c519dc7bf8203d42c8bd9388d42d848389284cbbf84a390f50a79c7b89f
+
+pkgname = python-dscribe
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fd1ecf5bbe17
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Alexander Bocken <alexander@bocken.org>
+
+_name=dscribe
+pkgname=python-${_name,,}
+pkgver=2.1.0
+pkgrel=1
+pkgdesc='Creating feature transformations in applications of ML to materials science'
+
+arch=('any')
+url="https://singroup.github.io/dscribe/"
+license=('Apache-2.0')
+depends=('python>3.7' 'pybind11>=2.4' python-numpy python-scipy 'python-ase>=3.19.0' python-scikit-learn 'python-joblib>=1.0.0' python-sparse)
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz"
+)
+sha256sums=('cbeb6c519dc7bf8203d42c8bd9388d42d848389284cbbf84a390f50a79c7b89f')
+
+makedepends=(python-build python-installer python-wheel meson-python)
+
+build() {
+ cd $_name-$pkgver
+ python -m build --wheel --no-isolation
+}
+
+package() {
+ cd $_name-$pkgver
+ python -m installer --destdir="$pkgdir" dist/*.whl
+}