summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTimothée Ravier2016-04-10 03:43:01 +0200
committerTimothée Ravier2016-04-10 03:43:51 +0200
commitdf8d150f1141ab9b84df0c44e4b870f8c7c648ed (patch)
treec3274381f57a543488d4b81ca40597dc51fbdf7b
parentc4c9e0e8a3a4b6c486e09fd2818ec1aab74d8545 (diff)
downloadaur-df8d150f1141ab9b84df0c44e4b870f8c7c648ed.tar.gz
Move to Python 3
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD22
2 files changed, 22 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ea52bbffd7bf..067437538634 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,18 @@
# Generated by mksrcinfo v8
-# Wed Mar 2 19:40:11 UTC 2016
-pkgbase = python2-dulwich
- pkgdesc = Dulwich is a pure-Python implementation of the Git file formats and protocols.
+# Sun Apr 10 01:34:54 UTC 2016
+pkgbase = python-dulwich
+ pkgdesc = Pure-Python implementation of the Git file formats and protocols
pkgver = 0.12.0
pkgrel = 1
- url = http://samba.org/~jelmer/dulwich/
+ url = https://www.dulwich.io/
arch = i686
arch = x86_64
license = GPL2
- depends = python2
+ depends = python
source = https://pypi.python.org/packages/source/d/dulwich/dulwich-0.12.0.tar.gz
- sha1sums = 02c214a6dd6a62321611d33317326e63dd164b11
+ sha256sums = 8f9070f37eec6175aab60d7064246b5b6453b2fab342589101f1c8feda0a0cc6
+ sha384sums = 8059b924d92d1001e911868ce7e272b0489c1e36be7da4e5278a77f0f17fe745524857e78fa2dd700b9dbf50b0ea213a
+ sha512sums = 55062a89d77294df849a8f59e0dd25c4d557fc3ea8e2de2c114c510ebe15ba876be54fad0889f1475855e3bf986f91e04b819dad3fe61f23b399553b59b26302
-pkgname = python2-dulwich
+pkgname = python-dulwich
diff --git a/PKGBUILD b/PKGBUILD
index 93358e117257..315165962e27 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,20 @@
-pkgname=python2-dulwich
+# Maintainer: Timothée Ravier <tim@siosm.fr>
+
+pkgname=python-dulwich
pkgver=0.12.0
pkgrel=1
-pkgdesc="Dulwich is a pure-Python implementation of the Git file formats and protocols."
+pkgdesc='Pure-Python implementation of the Git file formats and protocols'
arch=('i686' 'x86_64')
-url="http://samba.org/~jelmer/dulwich/"
+url='https://www.dulwich.io/'
license=('GPL2')
-depends=('python2')
-
-source=("https://pypi.python.org/packages/source/d/dulwich/dulwich-$pkgver.tar.gz")
-sha1sums=('02c214a6dd6a62321611d33317326e63dd164b11')
+depends=('python')
+source=("https://pypi.python.org/packages/source/d/dulwich/dulwich-${pkgver}.tar.gz")
package() {
- cd "$srcdir/dulwich-$pkgver"
- python2 setup.py install --root="$pkgdir" --optimize=1
+ cd "dulwich-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1
}
+
+sha256sums=('8f9070f37eec6175aab60d7064246b5b6453b2fab342589101f1c8feda0a0cc6')
+sha384sums=('8059b924d92d1001e911868ce7e272b0489c1e36be7da4e5278a77f0f17fe745524857e78fa2dd700b9dbf50b0ea213a')
+sha512sums=('55062a89d77294df849a8f59e0dd25c4d557fc3ea8e2de2c114c510ebe15ba876be54fad0889f1475855e3bf986f91e04b819dad3fe61f23b399553b59b26302')