summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortadly2018-09-13 16:48:38 +0200
committertadly2018-09-13 16:48:38 +0200
commit4e46acaba8d97ae577e876ff28234793f8c135d2 (patch)
treea68855c0e52c57b814ae71cf36b510976ff4ef93
parent5292216a22a44c1b71b2213387e0765ae3c0d1a4 (diff)
downloadaur-4e46acaba8d97ae577e876ff28234793f8c135d2.tar.gz
makes both dbus and gobject optional
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD8
-rw-r--r--python-dups.install15
3 files changed, 17 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f54dc937e2c6..c76dd3f796cb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-dups-git
pkgdesc = It deduplicates things - Backup as simple as possible.
- pkgver = r99.158b91a
+ pkgver = r131.333bd6a
pkgrel = 1
url = https://github.com/linuxwhatelse/dups
install = python-dups.install
@@ -9,11 +9,10 @@ pkgbase = python-dups-git
makedepends = python-setuptools
depends = python
depends = rsync
- depends = dbus
- depends = python-gobject
- depends = python-dbus
depends = python-paramiko
depends = python-ruamel-yaml
+ optdepends = python-dbus: Daemon support
+ optdepends = python-gobject: Desktop notification support
provides = python-dups
source = python-dups::git+https://github.com/linuxwhatelse/dups.git
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 8b7104032d4f..713076905da6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,14 @@
_pkgname=python-dups
pkgname=python-dups-git
-pkgver=r99.158b91a
+pkgver=r131.333bd6a
pkgrel=1
pkgdesc="It deduplicates things - Backup as simple as possible."
arch=("x86_64")
url="https://github.com/linuxwhatelse/dups"
license=('GPL3')
-depends=('python' 'rsync' 'dbus' 'python-gobject' 'python-dbus'
- 'python-paramiko' 'python-ruamel-yaml')
+depends=('python' 'rsync' 'python-paramiko' 'python-ruamel-yaml')
+optdepends=('python-dbus: Daemon support'
+ 'python-gobject: Desktop notification support')
makedepends=('python-setuptools')
provides=("${_pkgname}")
source=("${_pkgname}::git+https://github.com/linuxwhatelse/dups.git")
@@ -35,4 +36,3 @@ package() {
# vim: set syntax=sh:
-
diff --git a/python-dups.install b/python-dups.install
index d8410d8b896a..aa420ed35ef6 100644
--- a/python-dups.install
+++ b/python-dups.install
@@ -1,22 +1,27 @@
post_install() {
echo "---"
- echo "Reload user units with:"
+ echo "Start user unit with:"
echo " systemctl --user daemon-reload"
- echo ""
- echo "Start dups with:"
echo " systemctl --user start dups"
echo ""
+ echo "Start system unit with:"
+ echo " sudo systemctl daemon-reload"
+ echo " sudo systemctl start dups@${USER}"
+ echo ""
echo "To automatically start dups after login:"
echo " systemctl --user enable dups"
+ echo " sudo systemctl enable dups@${USER}"
echo "---"
}
post_upgrade() {
echo "---"
- echo ""
- echo "Restart dups with:"
+ echo "Restart user unit with:"
echo " systemctl --user daemon-reload"
echo " systemctl --user restart dups"
echo ""
+ echo "Restart system unit with:"
+ echo " sudo systemctl daemon-reload"
+ echo " sudo systemctl restart dups@${USER}"
echo "---"
}