summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrey Christoforo2018-11-12 16:51:52 +0000
committerGrey Christoforo2018-11-12 16:54:37 +0000
commit1ca7a070ab3d9f2126338be461e06e3714c1c833 (patch)
tree4782f7c4591a8e13e6274a9e3dedb8644aa00feb
downloadaur-1ca7a070ab3d9f2126338be461e06e3714c1c833.tar.gz
initial commit
add srcinfo
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD23
3 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5449734597a7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-dxfgrabber
+ pkgdesc = A Python library to grab information from DXF drawings - all DXF versions supported.
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/mozman/dxfgrabber.git
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ source = https://files.pythonhosted.org/packages/d0/d5/f4c1bc143223b4a2cc4e915e7e1956ef183fbe035e4a8525e336110a90ed/dxfgrabber-1.0.0.zip
+ md5sums = d87f166fe168ef8ab58c837cedd0c370
+
+pkgname = python-dxfgrabber
+ depends = python
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..a475b0441882
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*.tar*
+pkg/
+src/
+*.part
+*.zip
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..259e2b94b0e5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+pkgname=python-dxfgrabber
+_module='dxfgrabber'
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="A Python library to grab information from DXF drawings - all DXF versions supported."
+url="https://github.com/mozman/dxfgrabber.git"
+depends=('python')
+makedepends=('python-setuptools')
+license=('MIT')
+arch=('any')
+source=("https://files.pythonhosted.org/packages/d0/d5/f4c1bc143223b4a2cc4e915e7e1956ef183fbe035e4a8525e336110a90ed/dxfgrabber-${pkgver}.zip")
+md5sums=('d87f166fe168ef8ab58c837cedd0c370')
+
+build() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ depends+=()
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}