summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGaël Donval2016-09-03 17:48:44 +0200
committerGaël Donval2016-09-03 17:48:44 +0200
commitc7402eabdc2bc21cdf45932648dc6333be857c79 (patch)
tree02242c0e95dc0387b590250dda0404d827b470bc
downloadaur-c7402eabdc2bc21cdf45932648dc6333be857c79.tar.gz
Initial commit
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD46
2 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f7fb281cf2b5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = python-dynd
+ pkgdesc = Bindings for the C++ dynd array library (numpy array replacement).
+ pkgver = 0.7.2
+ pkgrel = 1
+ url = https://github.com/libdynd/dynd-python
+ arch = i686
+ arch = x86_64
+ groups = blaze-ecosystem
+ license = BSD
+ makedepends = python-setuptools
+ makedepends = python-numpy>=1.7.1
+ makedepends = cython>=0.24
+ makedepends = python>=3.4
+ makedepends = cmake>=2.8.11
+ depends = python-numpy>=1.7.1
+ depends = dynd=0.7.2
+ depends = python>=3.4
+ source = https://github.com/libdynd/dynd-python/archive/v0.7.2.tar.gz
+ md5sums = 8d50606db6975e181212c997843797f7
+ sha1sums = e0c6aa25df0f1dacb536d6e5c438b484f050e01c
+
+pkgname = python-dynd
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3a943b47f4e5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Gaël Donval <gdonval+aur at google mail>
+# Contributor: Gaël Donval <gdonval+aur at google mail>
+
+pkgbase='python-dynd'
+pkgname='python-dynd'
+pkgver=0.7.2
+pkgrel=1
+pkgdesc='Bindings for the C++ dynd array library (numpy array replacement).'
+groups=('blaze-ecosystem')
+arch=('i686' 'x86_64')
+url='https://github.com/libdynd/dynd-python'
+license=('BSD')
+makedepends=('python-setuptools'
+ 'python-numpy>=1.7.1'
+ 'cython>=0.24'
+ 'python>=3.4'
+ 'cmake>=2.8.11')
+depends=('python-numpy>=1.7.1' 'dynd=0.7.2' 'python>=3.4')
+source=("https://github.com/libdynd/dynd-python/archive/v${pkgver}.tar.gz")
+sha1sums=('e0c6aa25df0f1dacb536d6e5c438b484f050e01c')
+md5sums=('8d50606db6975e181212c997843797f7')
+
+prepare() {
+ cd "${srcdir}"/dynd-python-$pkgver
+ pwd
+ patch setup.py $startdir/set_version_without_git.patch
+}
+
+build() {
+ cd "${srcdir}"/dynd-python-$pkgver
+ args="-DCMAKE_BUILD_TYPE=RelWithDebInfo"
+ args="$args -DCMAKE_INSTALL_PREFIX=/usr"
+ args="$args -DCMAKE_CXX_FLAGS='-march=native -O3 -pipe -fstack-protector-strong'"
+ args="$args -DCMAKE_CXX_FLAGS_RELWITHDEBINFO='-DNDEBUG'"
+ python setup.py build_py -cO1
+ python setup.py build_ext --extra-cmake-args="$args"
+ python setup.py build_clib
+ python setup.py build_scripts
+}
+
+package_python-dynd() {
+ cd "${srcdir}"/dynd-python-$pkgver
+ python setup.py install --skip-build --prefix=/usr --root="$pkgdir" --optimize=1
+ install -D -m644 LICENSE* "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -D -m644 README* "${pkgdir}/usr/share/doc/${pkgname}/README"
+}