summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPierre-Marie de Rodat2020-06-14 10:18:48 +0200
committerPierre-Marie de Rodat2020-06-14 10:18:48 +0200
commit380ba56c7bf30e100258230206be2b9954454011 (patch)
treed2fa94992ce4a1d870cda833b6eedeb2cfbb92ff
parentb9ad4efac10c209d2991f97fd9c7fafce2cdfa76 (diff)
downloadaur-380ba56c7bf30e100258230206be2b9954454011.tar.gz
Add missing dependencies, patch to use distro (formerly ld)
-rw-r--r--PKGBUILD20
-rw-r--r--distro.patch21
2 files changed, 36 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3e349d00e4f4..e1f87217931f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname='python-e3-core'
pkgver='22.0.0'
-pkgrel=1
+pkgrel=2
pkgdesc="Framework to ease the development of portable automated build systems"
arch=('any')
@@ -10,18 +10,28 @@ url="https://github.com/AdaCore/e3-core"
license=('GPL3')
depends=('python-colorama'
- 'python-yaml'
+ 'python-distro'
'python-dateutil'
+ 'python-netifaces'
+ 'python-psutil'
'python-requests'
'python-requests-toolbelt'
+ 'python-stevedore>1.20.0'
'python-tqdm'
- 'python-stevedore>1.20.0')
+ 'python-yaml')
makedepends=('python-setuptools')
conflicts=('python2-e3-core')
_name='e3-core'
-source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
-sha512sums=('1544c9cce9d7bab32db4617f70eaab301a526f84f8d89a22e5204eb7a7823a8e0103e12d490101a95d6255f3274732dbd77467064c856e1a05f8e7e18cce9f5a')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz"
+ "distro.patch")
+sha512sums=('1544c9cce9d7bab32db4617f70eaab301a526f84f8d89a22e5204eb7a7823a8e0103e12d490101a95d6255f3274732dbd77467064c856e1a05f8e7e18cce9f5a'
+ '26ccd271cca25661ffc99154d44f210843f18e14641949d24d5a22bad0a62a449e5ed41eca1e5f8c409e504d20cccc9b5f9db3d2eadfc8214a02e26c6f99eee6')
+
+prepare() {
+ cd "$srcdir/$_name-$pkgver"
+ patch -Np0 -i "$srcdir/distro.patch"
+}
build() {
cd "$srcdir/$_name-$pkgver"
diff --git a/distro.patch b/distro.patch
new file mode 100644
index 000000000000..6e81033025a8
--- /dev/null
+++ b/distro.patch
@@ -0,0 +1,21 @@
+diff --git src/e3/os/platform.py src/e3/os/platform.py
+index 94964a6..5694ec8 100644
+--- src/e3/os/platform.py
++++ src/e3/os/platform.py
+@@ -73,12 +73,12 @@ class SystemInfo(object):
+
+ # Fetch linux distribution info on linux OS
+ if cls.uname.system == "Linux": # linux-only
+- import ld
++ import distro
+
+ cls.ld_info = {
+- "name": ld.name(),
+- "major_version": ld.major_version(),
+- "version": ld.version(),
++ "name": distro.name(),
++ "major_version": distro.major_version(),
++ "version": distro.version(),
+ }
+
+ # Fetch network interfaces