summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authororestisf2015-12-24 03:17:14 +0200
committerorestisf2015-12-24 03:17:14 +0200
commit7b671b379c8609674aae66a627851f2465d5e8f0 (patch)
tree497e57dbfd5b87e82a2952a16ec3d5cc5ac0d717
downloadaur-7b671b379c8609674aae66a627851f2465d5e8f0.tar.gz
Initial import
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD28
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a62214c3b941
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Thu Dec 24 01:15:30 UTC 2015
+pkgbase = python-easygui-git
+ pkgdesc = A module for very simple, very easy GUI programming in Python
+ pkgver = r101.12f7c9b
+ pkgrel = 3
+ url = https://github.com/robertlugg/easygui
+ arch = any
+ license = CCPL
+ makedepends = git
+ makedepends = python-setuptools
+ depends = python
+ depends = tk
+ provides = python-easygui
+ conflicts = python-easygui
+ source = git+https://github.com/robertlugg/easygui
+ sha256sums = SKIP
+
+pkgname = python-easygui-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..caa21e9136f7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Orestis Floros <orestisf1993@gmail.com>
+
+_pkgname=easygui
+pkgname=python-easygui-git
+pkgver=r101.12f7c9b
+pkgrel=3
+pkgdesc='A module for very simple, very easy GUI programming in Python'
+url='https://github.com/robertlugg/easygui'
+license=('CCPL')
+source=('git+https://github.com/robertlugg/easygui')
+sha256sums=('SKIP')
+arch=('any')
+depends=('python' 'tk')
+makedepends=('git' 'python-setuptools')
+conflicts=('python-easygui')
+provides=('python-easygui')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+
+ # Get the version number.
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+ python setup.py install --root=$pkgdir
+}