summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWhiredPlanck2023-05-20 00:16:45 +0800
committerWhiredPlanck2023-05-20 00:16:45 +0800
commit1103772f2433f9611ddfab17a7c38b85ff2ee9a2 (patch)
tree03fdde34670ecdb59b7f30e36cca4d6608a69a9b
parentaa111494a58dd04c4463d3b035ac462e2a23c629 (diff)
downloadaur-1103772f2433f9611ddfab17a7c38b85ff2ee9a2.tar.gz
Update to v1.6.2.r594.19db7ba
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD27
2 files changed, 35 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5cdef87327e8..a2c05eeeabe3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,30 +1,42 @@
pkgbase = python-easyocr-git
pkgdesc = Ready-to-use OCR with 40+ languages supported including Chinese, Japanese, Korean and Thai
- pkgver = 1.1.6.r297.a36bb9e
+ pkgver = 1.6.2.r594.19db7ba
pkgrel = 1
url = https://github.com/JaidedAI/EasyOCR
install = python-easyocr-git.install
arch = any
- license = Apache
+ license = Apache-2.0
makedepends = python-setuptools
makedepends = git
+ makedepends = ninja
depends = python-torchvision>=0.5
depends = python-scikit-image
depends = python-pytorch
- depends = opencv
- depends = hdf5
+ depends = python-opencv
+ depends = python-bidi
+ depends = python-pillow
+ depends = python-numpy
+ depends = python-yaml
+ depends = python-shapely
+ depends = python-pyclipper
+ depends = python-scipy
optdepends = python-torchvision-cuda>=0.5
provides = python-easyocr
conflicts = python-easyocr
replaces = python-easyocr
- source = git+https://github.com/JaidedAI/EasyOCR.git
+ source = git+https://github.com/JaidedAI/EasyOCR.git#commit=19db7ba78903d79ffc7d789bd0427e8023525a02
sha256sums = SKIP
pkgname = python-easyocr-git
depends = python-torchvision>=0.5
depends = python-scikit-image
depends = python-pytorch
- depends = opencv
- depends = hdf5
+ depends = python-opencv
+ depends = python-bidi
+ depends = python-pillow
+ depends = python-numpy
+ depends = python-yaml
+ depends = python-shapely
+ depends = python-pyclipper
+ depends = python-scipy
depends = python
-
diff --git a/PKGBUILD b/PKGBUILD
index 18fbe7f35640..0cc2a09bdd98 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,33 +2,36 @@
pkgname=python-easyocr-git
_name=EasyOCR
-pkgver=1.1.6.r297.a36bb9e
+_commit=19db7ba78903d79ffc7d789bd0427e8023525a02
+pkgver=1.6.2.r594.19db7ba
pkgrel=1
pkgdesc="Ready-to-use OCR with 40+ languages supported including Chinese, Japanese, Korean and Thai"
arch=("any")
url="https://github.com/JaidedAI/EasyOCR"
-license=("Apache")
+license=("Apache-2.0")
depends=(
'python-torchvision>=0.5' 'python-scikit-image'
- 'python-pytorch' 'opencv' 'hdf5'
+ 'python-pytorch' 'python-opencv' 'python-bidi'
+ 'python-pillow' 'python-numpy' 'python-yaml'
+ 'python-shapely' 'python-pyclipper' 'python-scipy'
)
-makedepends=('python-setuptools' 'git')
+makedepends=('python-setuptools' 'git' 'ninja')
#checkdepends=('python-pytest-runner')
optdepends=('python-torchvision-cuda>=0.5')
provides=('python-easyocr')
conflicts=('python-easyocr')
replaces=('python-easyocr')
-source=('git+https://github.com/JaidedAI/EasyOCR.git')
+source=("git+https://github.com/JaidedAI/EasyOCR.git#commit=${_commit}")
sha256sums=('SKIP')
install=${pkgname}.install
-prepare() {
- cd "$srcdir"/${_name} # -${pkgver}
- sed -i "s/opencv-python//g" requirements.txt
- #sed -i 's/Pillow<7.0/Pillow/g' setup.py
- cd easyocr
- sed -i '4d' detection.py
-}
+# prepare() {
+# cd "$srcdir"/${_name} # -${pkgver}
+# sed -i "s/opencv-python//g" requirements.txt
+# #sed -i 's/Pillow<7.0/Pillow/g' setup.py
+# cd easyocr
+# sed -i '4d' detection.py
+# }
build() {
cd "$srcdir"/${_name}