summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2022-04-07 09:38:39 -0500
committerLuis Martinez2022-04-07 09:38:39 -0500
commitc449d77df108c33ebea89687e9d29557654d0761 (patch)
tree82b855e800c446c1f7032acf1d9c5cbd30afec0f
parent71da3703c5bf1783749e282b8a776b0032deb591 (diff)
downloadaur-c449d77df108c33ebea89687e9d29557654d0761.tar.gz
update to 1.4.4
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD27
2 files changed, 27 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c3f5016ba109..9395c2166173 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,16 @@
pkgbase = python-easypysmb
- pkgdesc = Library wraps around the pysmb library
- pkgver = 1.4.3
+ pkgdesc = Easy to use PySMB wrapper library
+ pkgver = 1.4.4
pkgrel = 1
+ url = https://github.com/pschmitt/easypysmb
arch = any
+ license = GPL3
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-poetry
depends = python-pysmb
depends = python-pyasn1
- source = https://github.com/pschmitt/easypysmb/archive/1.4.3.tar.gz
- md5sums = c3c74647cc62c6cf216fc20d31554c90
+ source = python-easypysmb-1.4.4.tar.gz::https://files.pythonhosted.org/packages/source/e/easypysmb/easypysmb-1.4.4.tar.gz
+ sha256sums = 48111dc3c06535e6f20609e58373ab002b790762ad34296311d2f9dc12866786
pkgname = python-easypysmb
-
diff --git a/PKGBUILD b/PKGBUILD
index 479581edc265..8d2aae3396d4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,25 @@
-# Submitter: Michael Spradling <mike@mspradling.com>
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+# Contributor: Michael Spradling <mike@mspradling.com>
-_pkg="easypysmb"
-pkgname="python-$_pkg"
-pkgver=1.4.3
+pkgname=python-easypysmb
+_pkg=easypysmb
+pkgver=1.4.4
pkgrel=1
-pkgdesc='Library wraps around the pysmb library'
+pkgdesc='Easy to use PySMB wrapper library'
arch=('any')
+license=('GPL3')
+url='https://github.com/pschmitt/easypysmb'
depends=('python-pysmb' 'python-pyasn1')
-source=("https://github.com/pschmitt/$_pkg/archive/$pkgver.tar.gz")
-md5sums=('c3c74647cc62c6cf216fc20d31554c90')
+makedepends=('python-build' 'python-installer' 'python-poetry')
+source=("$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/e/$_pkg/$_pkg-$pkgver.tar.gz")
+sha256sums=('48111dc3c06535e6f20609e58373ab002b790762ad34296311d2f9dc12866786')
+
+build() {
+ cd "$_pkg-$pkgver"
+ python -m build --wheel --no-isolation
+}
package() {
- cd "$srcdir/$_pkg-$pkgver"
- python setup.py install --root="$pkgdir/" --optimize=1
+ cd "$_pkg-$pkgver"
+ PYTHONHASHSEED=0 python -m installer --destdir="$pkgdir/" dist/*.whl
}