summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGI_Jack2020-11-15 11:21:54 -0500
committerGI_Jack2020-11-15 11:21:54 -0500
commitda23a7a901a675d220736c3146d29cac8a4685a4 (patch)
tree296d9b4d1930de59fc16efa5df34c36e7f5042d5
downloadaur-da23a7a901a675d220736c3146d29cac8a4685a4.tar.gz
initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD30
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b0d1ea5eb658
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-ecpy
+ pkgdesc = Pure Python Elliptic Curve Library for Python
+ pkgver = 1.2.5
+ pkgrel = 1
+ url = https://github.com/ubinity/ECPy
+ arch = any
+ license = custom
+ makedepends = python
+ makedepends = python-setuptools
+ makedepends = python-future
+ source = python-ecpy-1.2.5::https://github.com/cslashm/ECPy/archive/1.2.5.tar.gz
+ sha256sums = 02a2e990fe4b9c51a5a2d7518439ad80e5d839c931f76fa5144c50543e6a103f
+
+pkgname = python-ecpy
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6855f22bdb6d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: GI Jack <GI_Jack@hackermail.com>
+
+pkgbase=python-ecpy
+pkgname='python-ecpy'
+pkgver=1.2.5
+pkgrel=1
+arch=('any')
+pkgdesc='Pure Python Elliptic Curve Library for Python'
+url='https://github.com/ubinity/ECPy'
+license=('custom')
+source=("${pkgname}-${pkgver}::https://github.com/cslashm/ECPy/archive/1.2.5.tar.gz")
+sha256sums=('02a2e990fe4b9c51a5a2d7518439ad80e5d839c931f76fa5144c50543e6a103f')
+makedepends=('python' 'python-setuptools' 'python-future')
+
+build() {
+ cd ECPy-${pkgver}
+ python setup.py build
+}
+
+package() {
+ cd ECPy-${pkgver}
+ python setup.py install --root="${pkgdir}" --optimize=1
+ # Install License
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ # Install Documentation
+ install -D -m644 README.rst "${pkgdir}/usr/share/doc/${pkgname}/README.rst"
+}
+
+
+