summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathan Yantis2018-01-13 23:19:48 -0800
committerJonathan Yantis2018-01-13 23:19:48 -0800
commit9591a546adec7e29dd3d3f2a24e3246c7568fb88 (patch)
treef4e50f90f62cc98ba62934a9edf034729a305bf4
downloadaur-9591a546adec7e29dd3d3f2a24e3246c7568fb88.tar.gz
PKGBUILD
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD91
2 files changed, 119 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..110ab36b55de
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = python-ecpy-git
+ pkgver = 0.8.0.r24.1d3bdd4
+ pkgrel = 1
+ url = https://github.com/ubinity/ECPy
+ arch = any
+ license = custom
+ makedepends = git
+ makedepends = python
+ makedepends = python2
+ makedepends = python-setuptools
+ makedepends = python2-setuptools
+ source = git+https://github.com/ubinity/ECPy.git
+ sha256sums = SKIP
+
+pkgname = python-ecpy-git
+ pkgdesc = Pure Python Elliptic Curve Library for Python 3
+ depends = python
+ depends = python-future
+ provides = python-ecpy
+ conflicts = python-ecpy
+
+pkgname = python2-ecpy-git
+ pkgdesc = Pure Python Elliptic Curve Library for Python 2
+ depends = python2
+ depends = python2-future
+ provides = python2-ecpy
+ conflicts = python2-ecpy
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c9c81191e7a4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,91 @@
+# Maintainer: jyantis <yantis@yantis.net>
+
+pkgbase=python-ecpy-git
+pkgname=('python-ecpy-git' 'python2-ecpy-git')
+pkgver=0.8.0.r24.1d3bdd4
+pkgrel=1
+arch=('any')
+url='https://github.com/ubinity/ECPy'
+license=('custom')
+source=('git+https://github.com/ubinity/ECPy.git')
+sha256sums=('SKIP')
+makedepends=('git'
+ 'python'
+ 'python2'
+ 'python-setuptools'
+ 'python2-setuptools')
+
+pkgver() {
+ cd ECPy
+ set -o pipefail
+ _gitversion=$( git describe --long | sed -r 's/([^-]*-g)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)" )
+
+ # If there is a setup.py then pull the version tag from the file
+ if [ -f "setup.py" ]; then
+ if grep --quiet "version = " setup.py; then
+ printf "%s.%s" "$(grep -R "version = " setup.py | awk -F\' '{print $2}')" $_gitversion | sed 's/-/./g'
+ elif grep --quiet "version=" setup.py; then
+ printf "%s.%s" "$(grep -R "version=" setup.py | awk -F\' '{print $2}')" $_gitversion | sed 's/-/./g'
+ else
+ printf "%s" $_gitversion
+ fi
+ else
+ printf "%s" $_gitversion
+ fi
+}
+
+build() {
+ cd ECPy
+ python setup.py build
+ python2 setup.py build
+}
+
+package_python-ecpy-git() {
+ pkgdesc='Pure Python Elliptic Curve Library for Python 3'
+ depends=('python' 'python-future')
+ provides=('python-ecpy')
+ conflicts=('python-ecpy')
+
+ cd ECPy
+
+ # We don't need anything related to git in the package
+ rm -rf .git*
+
+ python setup.py install --root="${pkgdir}" --optimize=1
+
+ # Install License
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+ # Install Documentation
+ install -D -m644 README.rst "${pkgdir}/usr/share/doc/${pkgname}/README.rst"
+}
+
+package_python2-ecpy-git() {
+ pkgdesc='Pure Python Elliptic Curve Library for Python 2'
+ depends=('python2' 'python2-future')
+ provides=('python2-ecpy')
+ conflicts=('python2-ecpy')
+
+ cd ECPy
+
+ # Patch any #!/usr/bin/python to #!/usr/bin/python2
+ for file in $(find . -name '*.py' -print); do
+ sed -r -i 's_^#!.*/usr/bin/python(\s|$)_#!/usr/bin/python2_' $file
+ sed -r -i 's_^#!.*/usr/bin/env(\s)*python(\s|$)_#!/usr/bin/env python2_' $file
+ done
+
+ # We don't need anything related to git in the package
+ rm -rf .git*
+
+ python2 setup.py install --root="${pkgdir}" --optimize=1
+
+ # Install License
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+ # Install Documentation
+ install -D -m644 README.rst "${pkgdir}/usr/share/doc/${pkgname}/README.rst"
+}
+
+
+# vim:set ts=2 sw=2 et: