summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLaurent Brock2023-05-05 18:44:52 +0200
committerLaurent Brock2023-05-05 18:44:52 +0200
commit392086ca9f31d267cd838b2708f9be3aa4763c43 (patch)
tree71f7a918dc213535b2407091d62748d8e14d35de
parente44b890fcd76665373b385a67a0a9d65ad3243cf (diff)
downloadaur-392086ca9f31d267cd838b2708f9be3aa4763c43.tar.gz
Followed Arch Wiki, should be final commit for version
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD20
2 files changed, 11 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1474a94d480d..98a9db925663 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-edge-tts
pkgdesc = Use Microsoft Edge's online text-to-speech service from within your Python code or using the provided edge-tts or edge-playback command
pkgver = 6.1.5
- pkgrel = 4
+ pkgrel = 5
url = https://github.com/rany2/edge-tts
arch = any
license = GPL3
@@ -18,6 +18,8 @@ pkgbase = python-edge-tts
depends = python-attrs
depends = python-idna
depends = python-build
+ depends = python-installer
+ depends = python-wheel
optdepends = mpv: immediate tts playback with the provided edge-playback command
source = https://files.pythonhosted.org/packages/57/9b/c210806c9179e366254840014cd339e8f84453d7d562c9c9299635ecd043/edge-tts-6.1.5.tar.gz
sha256sums = 20b2a561989203bc7dbc63434da4b2078453e7d8cb068e51c39b446de22431c0
diff --git a/PKGBUILD b/PKGBUILD
index 27686aec6e8f..97ca7e76f41c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,12 +3,12 @@
_pkgname=edge-tts
pkgname=python-${_pkgname}
pkgver=6.1.5
-pkgrel=4
+pkgrel=5
pkgdesc="Use Microsoft Edge's online text-to-speech service from within your Python code or using the provided edge-tts or edge-playback command"
arch=(any)
url=https://github.com/rany2/edge-tts
license=(GPL3)
-depends=(python python-aiohttp python-yarl python-frozenlist python-async-timeout python-multidict python-charset-normalizer python-aiosignal python-attrs python-idna python-build)
+depends=(python python-aiohttp python-yarl python-frozenlist python-async-timeout python-multidict python-charset-normalizer python-aiosignal python-attrs python-idna python-build python-installer python-wheel)
makedepends=(
git
python-setuptools
@@ -21,21 +21,17 @@ source=(https://files.pythonhosted.org/packages/57/9b/c210806c9179e366254840014c
sha256sums=('20b2a561989203bc7dbc63434da4b2078453e7d8cb068e51c39b446de22431c0')
pkgver() {
- cd edge-tts-${pkgver}
+ cd ${_pkgname}-${pkgver}
awk 'FNR==3{print $2}' PKG-INFO
}
build() {
- cd edge-tts-${pkgver}
- python -m build
+ cd ${_pkgname}-${pkgver}
+ python -m build --wheel --no-isolation
}
package() {
- cd edge-tts-${pkgver}/dist
- python -m pip install --root-user-action=ignore edge_tts-${pkgver}-py3-none-any.whl
- install -Dm 644 ../LICENSE -t "${pkgdir}"/usr/share/licenses/edge-tts/
-}
-
-post_remove() {
- python -m pip uninstall edge-tts -y
+ cd ${_pkgname}-${pkgver}
+ python -m installer --destdir="${pkgdir}" dist/*.whl
+ install -Dm 644 LICENSE -t "${pkgdir}"/usr/share/licenses/edge-tts/
}