summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLaurent Brock2023-05-05 18:04:33 +0200
committerLaurent Brock2023-05-05 18:04:33 +0200
commita25d13bad79c954899d0f58175a1efec9a1e745b (patch)
tree12df20eeca7f9677193deb1983f6781e5f90db2f
parent0b088d263dc2bef79bc71b835a4ae9327ac12888 (diff)
downloadaur-a25d13bad79c954899d0f58175a1efec9a1e745b.tar.gz
Update to ver. 6.1.5 -- migrate away from setup.py
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD14
2 files changed, 12 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 50a9a10ad73b..a1d72a19c54d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-edge-tts
pkgdesc = Use Microsoft Edge's online text-to-speech service from within your Python code or using the provided edge-tts or edge-playback command
- pkgver = 6.1.3
+ pkgver = 6.1.5
pkgrel = 1
url = https://github.com/rany2/edge-tts
arch = any
@@ -17,8 +17,9 @@ pkgbase = python-edge-tts
depends = python-aiosignal
depends = python-attrs
depends = python-idna
- optdepends = mpv: immediate tts playback with provided edge-playback tool
- source = https://files.pythonhosted.org/packages/84/2c/5a6f5d2a5f2cd393533eeab239177c1ce4f5c05b36de4048e2281e3d1c57/edge-tts-6.1.3.tar.gz
- sha256sums = 4eb0e782626d06211256c726e42e4e42c3315c0f4fee2fc2394763b1aa8a80e7
+ depends = python-build
+ optdepends = mpv: immediate tts playback with the provided edge-playback command
+ source = https://files.pythonhosted.org/packages/57/9b/c210806c9179e366254840014cd339e8f84453d7d562c9c9299635ecd043/edge-tts-6.1.5.tar.gz
+ sha256sums = 20b2a561989203bc7dbc63434da4b2078453e7d8cb068e51c39b446de22431c0
pkgname = python-edge-tts
diff --git a/PKGBUILD b/PKGBUILD
index 460db7ec93eb..c37248a3e538 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,23 +2,23 @@
_pkgname=edge-tts
pkgname=python-${_pkgname}
-pkgver=6.1.3
+pkgver=6.1.5
pkgrel=1
pkgdesc="Use Microsoft Edge's online text-to-speech service from within your Python code or using the provided edge-tts or edge-playback command"
arch=(any)
url=https://github.com/rany2/edge-tts
license=(GPL3)
-depends=(python python-aiohttp python-yarl python-frozenlist python-async-timeout python-multidict python-charset-normalizer python-aiosignal python-attrs python-idna)
+depends=(python python-aiohttp python-yarl python-frozenlist python-async-timeout python-multidict python-charset-normalizer python-aiosignal python-attrs python-idna python-build)
makedepends=(
git
python-setuptools
)
optdepends=(
- 'mpv: immediate tts playback with provided edge-playback tool'
+ 'mpv: immediate tts playback with the provided edge-playback command'
)
-source=(https://files.pythonhosted.org/packages/84/2c/5a6f5d2a5f2cd393533eeab239177c1ce4f5c05b36de4048e2281e3d1c57/edge-tts-${pkgver}.tar.gz)
-sha256sums=('4eb0e782626d06211256c726e42e4e42c3315c0f4fee2fc2394763b1aa8a80e7')
+source=(https://files.pythonhosted.org/packages/57/9b/c210806c9179e366254840014cd339e8f84453d7d562c9c9299635ecd043/edge-tts-${pkgver}.tar.gz)
+sha256sums=('20b2a561989203bc7dbc63434da4b2078453e7d8cb068e51c39b446de22431c0')
pkgver() {
cd edge-tts-${pkgver}
@@ -27,11 +27,11 @@ pkgver() {
build() {
cd edge-tts-${pkgver}
- python setup.py build
+ python -m build
}
package() {
cd edge-tts-${pkgver}
- python setup.py install --root=$pkgdir --optimize=1 --skip-build
+ python -m pip install --root=$pkgdir
install -Dm 644 LICENSE -t "${pkgdir}"/usr/share/licenses/edge-tts/
}